forbidden error since last update (debian squeeze)

Discussion in 'General' started by dranach, Dec 19, 2011.

  1. dranach

    dranach New Member

    Since my last update 2 days ago, I cannot acces my websites anymore. I get a 403 forbidden error. To what ailment is this the symptom? Anybody else have this problem?

    I am running ispconfig 3.0.4.1 on debian squeeze.

    Thanks in advance
     
  2. chume

    chume Member

    I encountered the same error yesterday after upgrading to 3.0.41 and found out that the web folder in the /var/www folder is owned by root.root instead of the webx.clientx user.

    Everything started working after the ownership of /var/www/domain.com/web is changed.

    I hope this helps.
     
  3. till

    till Super Moderator

    Please ensure that the security level is set to high under system > server config > web.
     
  4. dranach

    dranach New Member

    Everything in /var/www/domain/web is set to webx.clientx, except for the stats-folder (owned by root). I cross-checked with another site, on another server, where the stats-folder is owned by root.root too.

    I failed to mention that the upgrade concerned the Debian Squeeze distribution. Ispconfig already was 3.0.4.1
     
  5. dranach

    dranach New Member

    I checked, it is set to 'high'
     
  6. till

    till Super Moderator

    Take alook at the error.log of the wesbite and post the error message that you find there for the forbidden error.
     
  7. dranach

    dranach New Member

    Problem is solved by putting back a complete image of the server. This is some kind of a brute force solution because it was becoming urgent. Consequently I still cannot tell what the underlying problem was..
    I will come back if it manifests itself again.

    In the meantime I have a problem with another website, where the page remains blank. I'll check first for a solution myself. If necessary I'll start a new thread for it.

    Thank you all for your efforts, though.

    Toni
     

Share This Page