Forbbiden .htaccess

Discussion in 'Installation/Configuration' started by mbria, Nov 15, 2007.

  1. mbria

    mbria New Member

    Hi all,

    Some months ago I setup my ubuntu 7.04 server and everything looks like was working fine.

    ISPconfig was capital (to simplify the administration) and I'm quite concerned about security, so I followed the ubuntu 7.04 perfect setup and after this I applied suPHP howto and an specific howto for Drupal CMS.

    My installations is just for a few people (just 30 users) so right now I only have web1 and web3 sites active.

    Web1 site works like a charm, but yesterday I noticed that web3 subfolders always return a 403 error.

    My goal is allowing my final users to install different CMSs on different subfolders. As you know, running different .htaccess is important to have Drupal, Joomla, Gallery all together in a single site.

    Getting this 403 error I reviewed web3 error log where I found that:

    Code:
    [Thu Nov 15 15:31:58 2007] [crit] [client 87.219.22.99] (13)Permission denied: /var/www/web3/web/video/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable
    I didn't see any other useful information in any other log.

    So I checked privileges four times (all files are web3_admin:web3 and I also temporally set .htaccess to 777 to be full sure was reachable) with same 403 results.

    Finally I created an empty folder with 777 and web3 user/group (and without any .htaccess inside) but I still get the same error.

    I need to say that Drupal is required in quite every site I create, so I decided to edit a "retailed" .htaccess (as is suggested in a howto) and changed apache2.conf with the following general directives:

    Code:
    <Directory /var/www/*/web>
        Options +Includes -Indexes
        #AllowOverride None
        AllowOverride All
        AllowOverride Indexes AuthConfig Limit FileInfo
        Order allow,deny
        Allow from all
        <Files ~ "^\.ht">
        Deny from all
        </Files>
    </Directory>
    
    <Directory /var/www/*/user/*/web>
        Options +Includes -Indexes
        AllowOverride None
        AllowOverride Indexes AuthConfig Limit FileInfo
        Order allow,deny
        Allow from all
        <Files ~ "^\.ht">
        Deny from all
        </Files>
    </Directory>
    I also tried adding similar stuff to each site's Apache Directives:

    Code:
    <Directory /var/www/web1/web>  
    Options +Includes +FollowSymlinks -Indexes  
    AllowOverride All  
    Order allow,deny  
    Allow from all  
    <Files ~ "^\.ht">  
    Deny from all  
    </Files>  
    </Directory>
    
    <Directory /var/www/web1/*/files>  
    SetHandler Drupal_Security_Do_Not_Remove_See_SA_2006_006
    Options None
    Options +FollowSymLinks
    </Directory>
    But nothing changes: web3 root works fine (a drupal is running) but I'm unable to reach web3 new subfolders... while (as I said) web1 is perfectly working with 3 Drupal installations, 1 OpenJournalSystem, 2 Joomlas and 1 moodle on it...

    Sorry for the long report, but I feel lost so I didn't know what information was important to be reported.

    Thanks a lot in advance for your help,

    Marc.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the output of:

    ls -la /var/www/web3/web/video/.htaccess
     
  3. mbria

    mbria New Member

    Redable for everybody

    Redable for everybody :-(

    Code:
    [email protected]:~# ls -la /var/www/web3/web/video/.htaccess
    -rw-r--r-- 1 web3_admin web3 178 2007-11-15 13:23 /var/www/web3/web/video/.htaccess
    Thanks for your help,

    m.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    ls -la /var/www/web3/web/video
    ?
     
  5. mbria

    mbria New Member

    Symbolic Link to real folder...

    Code:
    [email protected]/# ls -la /var/www/web3/web/video
    lrwxrwxrwx 1 web3_admin web3 18 2007-11-15 18:34 /var/www/web3/web/video -> subsites/filmforge
    And...

    Code:
    [email protected]:/# ls -la /var/www/web3/web/subsites/filmforge
    total 192
    drwxr-sr-x  9       1080 1080  4096 2007-10-17 23:35 .
    drwxrwxr-x  4 web3_admin web3  4096 2007-11-15 19:06 ..
    -rw-r--r--  1       1080 1080 30277 2007-10-17 23:28 CHANGELOG.txt
    -rw-r--r--  1       1080 1080   262 2006-08-09 09:42 cron.php
    -rw-r--r--  1       1080 1080  3696 2007-09-21 14:24 .htaccess
    drwxr-sr-x  2       1080 1080  4096 2007-10-17 23:35 includes
    -rw-r--r--  1       1080 1080   872 2006-12-12 10:32 index.php
    -rw-r--r--  1       1080 1080  1431 2006-09-08 18:29 INSTALL.mysql.txt
    -rw-r--r--  1       1080 1080  1073 2006-09-08 18:29 INSTALL.pgsql.txt
    -rw-r--r--  1       1080 1080 22238 2007-10-17 23:28 install.php
    -rw-r--r--  1       1080 1080  9263 2007-07-26 07:29 INSTALL.txt
    -rw-r--r--  1       1080 1080 18064 2006-07-09 13:33 LICENSE.txt
    -rw-r--r--  1       1080 1080  1778 2006-12-11 18:09 MAINTAINERS.txt
    drwxr-sr-x  3       1080 1080  4096 2007-10-17 23:35 misc
    drwxr-sr-x 31       1080 1080  4096 2007-10-17 23:35 modules
    drwxr-sr-x  3       1080 1080  4096 2007-10-17 23:35 profiles
    -rw-r--r--  1       1080 1080  1681 2007-03-23 19:57 robots.txt
    drwxr-sr-x  2       1080 1080  4096 2007-10-17 23:35 scripts
    drwxr-sr-x  4       1080 1080  4096 2007-10-17 23:35 sites
    drwxr-sr-x  7       1080 1080  4096 2007-10-17 23:35 themes
    -rw-r--r--  1       1080 1080 30510 2007-04-08 02:54 update.php
    -rw-r--r--  1       1080 1080  2941 2007-01-09 10:16 UPGRADE.txt
    -rw-r--r--  1       1080 1080   352 2005-12-10 20:26 xmlrpc.php
    
    Is it right?
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Please try this:
    Code:
    chmod 755 /var/www/web3/web/subsites/filmforge
     
  7. mbria

    mbria New Member

    It works :)

    Thanks a lot falko for your suggestion. It fixed the issue.

    And sorry a lot for my silence. I don't want to be one of those that disappear from this community as soon as they fixed their issue. ;-)

    Cheers,

    m.
     

Share This Page