Followed how-to for Fedora Core 4, now need to add to PHP

Discussion in 'Installation/Configuration' started by syst5253, Mar 30, 2006.

  1. syst5253

    syst5253 New Member

    I followed the Fedora Core 4 HowTo, and now I need to have postgresql running.

    I have installed everything, but I get this error:

    Your PHP installation does not support PostgreSQL. You need to recompile PHP using the --with-pgsql configure option.

    Where do I run this from?

  2. falko

    falko Super Moderator ISPConfig Developer

    Which PHP shows this error? Your main one, or ISPConfig's PHP (if ISPConfig is installed)?
  3. syst5253

    syst5253 New Member

    My main one, I have some systems that require postgresql, and when I try to run phppgadmin, I get the error. I have not yet installed ISPConfig
    Last edited: Mar 30, 2006
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you install the php postgresql package? I dont think it is installed in the howto.
  5. syst5253

    syst5253 New Member

    I installed it afterwards, postgresql, postgresql-server and php-pgsql

    It is running, but it needs to be configured in php
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Please have a look at your php.ini file if the postgresql .so extension is enabled.
  7. syst5253

    syst5253 New Member

    D'oh!! Thanks!!

Share This Page