Fobidden msg after fresh install

Discussion in 'Installation/Configuration' started by telpacity, Jun 19, 2011.

  1. telpacity

    telpacity New Member

    All, i just installed ispconfig 3 on centos 5.6 with no errors up until the actual php install. Im pretty sure i know what the problem is, i just do not know how to fix and im sure im no the first person to run into this.

    During the install (right after the sql/ssl questions) it finishes but mentions ispconfig and ispapps users/groups (or similiar to that) could not be added. More than likely it tried to use 'useradd blah blah' however it would need /sbin/useradd on my machine... which is why it outputted that error. I added them manually to the best of my knowledge but i will get forbidden when trying to access the ispconfig website. I just uninstalled ispconfig and made sure the ispconfig dir's in /var/www and /usr/local are deleted. Whats the best way to run the install or modify it so it uses the /sbin/useradd. I could not find where it performs that command in the install dir. Any help/ideas is much appreciated!

    FYI, everything else runs, httpd (phpmyadmin/webmail) etc runs. I just cant access ispconfig in my browser...
     
  2. falko

    falko Super Moderator

    What's the output of
    Code:
    getenforce
    ?

    Is this a physical server or a virtual machine?
     
  3. telpacity

    telpacity New Member

    [root@43172 web]# /usr/sbin/getenforce
    Disabled


    This is a dedicated server i own.

    With the above disabled, you think thats the problem?

    You think the main problem is me manually adding the ispapps/ispconfig user manually?
    Maybe i didnt do it correctly? I saw this on another post...

    "chown: `ispconfig:ispconfig': invalid user
    chown: `getmail': invalid user

    All I had to do to fix it was to add /sbin and /usr/sbin to the path, drop the database and reinstall ispconfig!"

    WHere do you add the /sbin and/or /usr/sbin so it picks it up in the script? I would rather the script do all the user adding and chowning rather than me... Thanks!
     
    Last edited: Jun 20, 2011
  4. telpacity

    telpacity New Member

    Ok, i am now able to access and configure however, i had to manually add the web1 user and chown the appropriate dirs.

    what i did to access site:
    added /usr/sbin to the lib/installer file
    added :apache to to the end of the group in 'group'

    any ideas why it wont auto add the clients i create in the panel?
     

Share This Page