Flash Content + ISP Config ?!

Discussion in 'General' started by MetraDynamix, Jul 17, 2006.

  1. MetraDynamix

    MetraDynamix New Member

    I am very confused and very stuck! I followed the Perfect Setup for Ubuntu 6.06 and installed ISPConfig. ISPConfig seems to be working properly. I am able to create Sites and access them when associating domains to them.

    When I place Flash contents in my pages it is not displaying at all. Even on Windows machines with IE. I have never seen something like this before?! I was using RHEL 4 before and flash was functioning perfectly fine. If I look at the source of the pages it does show that the code for the Flash Content. It is as if this installation is somehow blocking Flash Content.

    Any help would be highly appreciated!
     
  2. Ben

    Ben ISPConfig Developer ISPConfig Developer

    Did you check your apachelog, if your flashstuff gets downloaded oder causes any other error?
     
  3. fobicodam

    fobicodam ISPConfig Developer ISPConfig Developer

    Wait a minute, are we talking about Flash? the Macromedia software for animated things? this is a client component, ispconfig has no relation with what you put inside your pages !

    Look for errors on other places, check if your .swf file is uploaded in the place when it should be, put the .swf address right into your explorer, did it open? is there any security setting in your computer? IE ussualy block any "insecure component", this is NOT a server issue.
     
  4. MetraDynamix

    MetraDynamix New Member

    It has to be a server issue!

    And that is the reason why I decided to post for assistance. Because this is completely non-logical for as well. It works under RHEL4. I even took another physical computer, no a VM(Virtual Machine) this morning. Re-configured it completely to the letter, with Ubuntu 6.06 + ISPConfig. I created a Client, etc... Tied it to my domain, uploaded a simple HTML file with a flash button and bang! Same problem. There is something that is making Flash (Yes Macromedia Flash) not functioning when hosted on this server. I just cannot figure it out! It will show all other contents, but make the flash not appear at ALL! I tested it in Mozilla, IE, Opera etc... Its only when hosting it on this particular setup with Ubuntu 6.06 + ISPConfig the latest following the Perfect How-to. I just can't understand where the problem is! I look at the source code on the client side, and it shows all of the code for the flash, but nothing appears on the page. I have apache running on RHEL4, placed the same pages or sites, and everything works fine.

    Does anyone have any idea of what is causing this problem? Maybe apache is blocking something? DNS not configured right, I don't know anymore!
     
  5. fobicodam

    fobicodam ISPConfig Developer ISPConfig Developer

    The problem here is that you are looking for errors on wrong places. Your problem is on your client side, thats why it doesnt work on any host. Did you try lowering your security settings? If you go to another site with flash can you see it? can you call directly the .swf file?

    Its not a server problem. (unless some right doesnt allow the webserver read the file..)
     
  6. MetraDynamix

    MetraDynamix New Member

    Please Help!


    I am new to Ubuntu and and some things such as ISPConfig, but I am very experienced with other things. I have been trying to explain that I know that it is not a client-side issue. Yes, other Flash Sites work. I tried from different computers, thus the odds of all of these computers and their browsers beeing flash-not-happy is 0. There has to be something in the way the server is configured that is blocking the flash-content. I am not sure how Apache interprets this content. Perhaps a permission issue yes. That is the reason why I am so confused, to me this problem is not very logical. I looked into the apache logs, the ones that I could find... I cannot locate anything in the error logs... I do not want to give up on this issue as I really want to start utilizing Linux and learning it... Anyone has any ideas of where I should be looking. It is not a Client Side issue.

    I will admit that perhaps I am not configuring something right in ISPConfig or doing something wrong... Here is some more information....

    I tried with Suexec and without. Compiled and configured ISPConfig once with and the other time without it. Meaning that once I tried serving from /home/www and now from /var/www

    I checked CGI Scripts, PHP Scripts, FTP Access, MySQL for my site in the ISPConfig. Invidiual error pages, and Maildir. I also tried with various other combinations...

    I am completely ignorant when it comes to DNS.. I did attempt to learn as much as I could but I am a bit confused on how it works.. I have a domain...
    When I configured Ubuntu with the How-to, I utilized web01 instead of server1 and placed my domain. Thus web01.mydomain.com

    Hostname and Hostname -f command does show web01.mydomain.com
    ISPConfig does show under ISPConfig Settings -> DNS
    Ns1: web01.mydomain.com
    Ns2: web01.mydomain.com

    I did go to my registrar which is internic.ca and replaced their two DNS servers that they had with my internet IP Address. Which I was a bit confused considering the fact that it wants two DNS Servers Primary and Secondary. I deleted their two name servers, and place in IP for Primary and Secondary my IP Address. From what I understand this should work, but not give me redundancy, which I do not care for at the moment...

    My router is port forwarding DNS TCP/UDP, Web-80, FTP-21, Mail Pop-3 all to the server in question which has Ubuntu and ISPConfig...

    I am using the internal IP address of 192.168.2.8; This is where I think that I may have went wrong.. but under ISPConfig, I have the following settings for Server.

    Hostname: web01
    Domain: mydomain.com
    IP Address: 192.168.2.8
    Netmask: 255.255.255.0
    IP List: I added my internet IP in that list.

    I know that it is a lot to ask at once.. I just wish to make this work and I am very lost at the moment. DNS is my biggest challenge it seems that I cannot just grasp exactly how to configure it perfectly, I am not sure if it could be playing a part in the problem...

    If I could just understand the DNS portion, I think that things could be much better for me. Then in terms of the Flash problem, I am convinced that it is something with the way that DNS is addressing things and not downloading files properly OR that it has to do with something in the Apache permissions.

    I created a user under ISPConfig; as it is the only method that I found that will give you FTP access. I use dreamweaver, FTP on my LAN to 192.168.2.8
    I downloaded the entire content of the site; opened index.html which was under /web ... added some flash, uploaded it.

    Any help is much appreciated!
     
    Last edited: Jul 17, 2006
  7. fobicodam

    fobicodam ISPConfig Developer ISPConfig Developer

    Again, if you see your html page (without the flash) its not a server error. Is your server public? can we access it?
     
  8. MetraDynamix

    MetraDynamix New Member

    Yes, here is the URL:

    http://www.meganetworksolutions.com

    I think that I broke something... because now as my post for help with DNS it doesnt route to the proper place anymore... Dual problem now! To be honest it was not a client issue with the flash... something with that config was messing-up flash content only.

    Now I have to fix the DNS issues before again looking at the flash issues. Any help would be appreciated;
     
  9. Ben

    Ben ISPConfig Developer ISPConfig Developer

    Well my firefox did not display any flahs, but with direct access, e.g. http://www.meganetworksolutions.com/mp3player.swf it worked.

    regarding the server side issue, that's why I was asking if you could see any (in)successfull access on that file...
     
  10. MetraDynamix

    MetraDynamix New Member


    Thanks for the help Ben, it is highly appreciated! Do you think that this means that something is messed-up with the server's access in terms of apache?
     
  11. fobicodam

    fobicodam ISPConfig Developer ISPConfig Developer

    You have javascripts errors:

    Line 1 Car 25
    Line 11: Object required
    Line 21: Object required
    Line 34: Object required
     
  12. fobicodam

    fobicodam ISPConfig Developer ISPConfig Developer

    Why are you so obssesed (??) with apache errors? its a client side error. The flash file is fine, apache is fine. Fix your javscript errors then let us check again.
     
  13. MetraDynamix

    MetraDynamix New Member

    Speaking of those! How come now it is using this script from the web server everytime that I drop a SWF in my pages? It seems that apache is doing so;
     
  14. fobicodam

    fobicodam ISPConfig Developer ISPConfig Developer

    Its javascript, its client side. Maybe you are using an old object not supported with new versions of explorers, its very common on javascript. Every version/distribution/source/manufacturer has his own javascript.
     
  15. MetraDynamix

    MetraDynamix New Member

    Thank you very much for all of the assistance it gave me a good direction for this problematic. I just noticed that with this config and server. A scripts folder was automatically generated with the install.....

    In that scripts folder there is a file called AC_RunActiveContent.js
    This is a javascript. Now what is messed-up, is that when you drop a SWF into a HTML page is has nothing to do with with Java at all. In this case it seems that when I drop SWF with dreamweaver its using this AC_RunActiveContent.js to parse that file.... That .js came with the installation and is automatically generated. Thus if there is a Java script problem, its seeding from that file. Now why does it via that file?
     
  16. MetraDynamix

    MetraDynamix New Member

    That is my point! The point is that I have no Java knowledge and never encoded any Java into my pages. They worked fine before being ported to this server. This server for some reason uses a Java Script that is in Scripts folder. For some reason it seems to automatically be used for content such as flash. Which means that if there are errors in terms of Java, these errors are coming from that .js and that .js isnt' mine it came like this and is being called without me calling it... Now does anyone have any idea of how to get rid of this problem?
     
  17. fobicodam

    fobicodam ISPConfig Developer ISPConfig Developer

    I didnt understand you, but ispconfig doesnt create any script folder..
     
  18. fobicodam

    fobicodam ISPConfig Developer ISPConfig Developer

    Sure, edit your html file, delete this:

    <script src="../Scripts/AC_RunActiveContent.js" type="text/javascript"></script>
    .....

    <script type="text/javascript">
    AC_FL_RunContent( 'codebase','http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0','width','467','height','136','src','mp3player','quality','high','pluginspage','http://www.macromedia.com/go/getflashplayer','movie','mp3player' ); //end AC code
    </script>
    <noscript>
    .....

    </noscript>



    This must work.
     
  19. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig does not use Java at all. The file ending .js is not Java, it is JavaScript and tneither the file AC_RunActiveContent.js is from ISPConfig nor your scripts folder is created by ISPConfig.

    You can be 100% sure that your problem is not related to the fact that you use ISPConfig on your server.

    Which software do you use to cretae and upload the site.
     
  20. MetraDynamix

    MetraDynamix New Member

    I am going to have to disagree on that.. Well you are perhaps correct on that fact... I created this setup 4 times now. Following the How-To by the letter; all the users and site that I create from ISPConfig have the scripts folder with that file in it.... I definitely never made that folder or that file either.....

    Maybe it was the setup? I tried this on blank boxes, follow the how-to and install ispconfig 2.2.3 ; and I looked and that folder is there with that file in all cases.

    So maybe this IPSConfig or Apache or Ubuntu is making this structure and making all of the content like SWF go via that .js which in return contains errors which makes it not display the content? I am now upgrading to 2.3.4 and I will see what happens.. Definitely something is making that folder and that file and is messing up my flash;
     

Share This Page