Flag / unflag spam with amavis

Discussion in 'Installation/Configuration' started by tfboy, Jan 13, 2015.

  1. tfboy

    tfboy Member

    Hi,
    I've been getting some legitimate email flagged as spam with amavis / clam on my ubuntu 14 perfect server installation.
    I can of course move the email from my junk folder back into my inbox, but the subject still has the ***spam*** prefix.
    Is there any way I can "teach" amavis and override the default detection flags so that future email doesn't end up in my junk?

    I think the email in question was flagged as spam because it started with "Dear friend".
    Code:
    X-Spam-Flag: YES
    X-Spam-Score: 5.034
    X-Spam-Level: *****
    X-Spam-Status: Yes, score=5.034 tagged_above=1 required=4.5
    tests=[DEAR_FRIEND=2.604, DNS_FROM_AHBL_RHSBL=2.438,
    HTML_MESSAGE=0.001, RCVD_IN_DNSWL_BLOCKED=0.001,
    RCVD_IN_MSPIKE_H4=-0.01, RCVD_IN_MSPIKE_WL=-0.01, SPF_PASS=-0.001,
    T_KAM_HTML_FONT_INVALID=0.01, URIBL_BLOCKED=0.001]
    autolearn=no autolearn_force=no
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The problem is that the AHBL realtime blacklist has been turned off and now flags all emails as spam (see
    DNS_FROM_AHBL_RHSBL in tests). Try to update spamassassin:

    sa-update

    and then restart amavis.
     
  3. tfboy

    tfboy Member

    Thanks Till, seems to have fixed the issue.
     

Share This Page