Fixing open_basedir restriction

Discussion in 'General' started by runbuck, Dec 28, 2009.

  1. runbuck

    runbuck New Member

    So, I switched to ISPconfig3 over the weekend. All good. Basic sites moved fine. However, when I tried to run the wordpress install on one site (via moving the wordpress install files into a sub-dir I created off that sites web root called "Blog") I got this error on the first step:
    I got similar error on subsequent steps. Basically, ispconfig3's php safe mode is blocking I assume. However there is no checkbox like in ispconfig2 to shut it off for that site.

    I googled around and saw comments from Till that such errors could be fixed by editing the vhost.conf.master and adding the directory to the open_bind statements in the file (2 places). So I added this:
    php_admin_value open_basedir /var/www/clients/client1/web3/web/blog
    After the two open_bind statements already in that file. Making it look like this (first instance shown):

    On trying the install page again (after stop/starting apache and resaving the site in ispconfig to regen the site specific vhosts - which i assume come from the vhosts.conf.master file.) i got nothing - same open_bind restriction error.

    Did I edit/add the open_bind statement incorrectly? If not, is there a better way to install wordpress for a site running on ispconfig3? I assume you should move the files to a sub-dir of the site /web directory (as that is how it used to work).

    Any thoughts appreciated.
    Last edited: Dec 28, 2009
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    All files of a website have to be licated in the web directory of this site. I run many wordpress installs, never had a problem with open_basedir when you install it into the web dir or a subdirectory of the web dir. So I never had to adjust the open_basedir path. You should check where you installed the files and copy them to a correct directory inside the web dir or the web dir itself.
  3. runbuck

    runbuck New Member

    DOH! Reinstall worked

    Till, thanks for thought. Fixed it.

    I had downloaded to the server and then moved the files (mv) to a sub-directory in the /web. That was the way that had it all whacked (not sure why).

    When I did it the second time, I downloaded to a win7 client and FTP'd to the web sub-dir for the blog. Then it worked.


    Regardless, your point that it worked got me to try again. Thanks. And I learned wayyyyy to much about open_basedir as I tried to resolve it the hard (stupid/wrong) way.:)
  4. Nuzman

    Nuzman New Member

    So then how do I write a PHP-based site which has access to the ISPConfig Remoting API? Do I have to create the site outside the scope of the ISPConfig interface (like when one installs RoundCube + the API integration)?
  5. haido92

    haido92 New Member

    You should check where you installed the files and copy them to a correct directory inside the web dir or the web dir itself.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Check out the exampl scripts in the remote_client folder of the ispconfig tar.gz file.

    It does not matter where you run the scripts as long as this server or desktop has a php interpreter installed and is connected to the internet, the OS can be windows, Linux or MAC and you can run them on your ispconfig server as well.
  7. Nuzman

    Nuzman New Member

    Thanks for pointing me to some example files. To clarify, when I said "outside the scope", I was referring to setting up a virtual host NOT via the ISPConfig interface, but directly on the server (via SSH). I wasn't referring to operating system.

    Again, thanks for taking the time to respond - greatly appreciated.

Share This Page