FIXED - [Warning] Access denied for user ''@'localhost' (using password: NO)

Discussion in 'General' started by edge, Apr 22, 2020.

  1. edge

    edge Active Member Moderator

    Warning.... Long time none active person here! Why?? Servers (Debian with ISPconfig) have been running great, and had absolutely no issues with them...
    .....

    I've installed a new server (Debain 10) some weeks ago, and this one is giving me a hell of a time!

    I used Till his excellent howto (The Perfect Server - Debian 10 (Buster) with Apache, BIND, Dovecot, PureFTPD and ISPConfig 3.1) to install the server.

    As mentioned above.... I'm having a hell of a time with this server. Normally I would reinstall something like this, but as it's in production now and as I do not want to migrate all the users again I hope that someone here can help me with one of the issues I'm having with the server.

    Okay. Here we go.

    I'm seeing every 2 minutes the following error in /var/mysql/error.log
    Okay.. Not much info.. So.. Looking at /var/log/syslog, I see that at this time interval postfix is doing it's thing.
    Anyone here who might have a clue here where to look, and how to fix this?
     
  2. edge

    edge Active Member Moderator

    [part 2]

    I've had a look at /etc/postfix/main.cf, but did not find anything wrong with it.

    Same with /etc/postfix/master.cf.. Nothing wrong as far as I can see.
    Again. Any help on this appreciated!
     
    Last edited: Apr 22, 2020
  3. Jesse Norell

    Jesse Norell ISPConfig Developer ISPConfig Developer

    Those are probably ISPConfig's service monitoring. You can turn it off in settings of you want.
     
    edge likes this.
  4. edge

    edge Active Member Moderator

    Hi Jesse. Thank you for your help.
    If you are talking about System > Server Configuration > domain > Rescue, HTTPD, MySQL and Email monitoring than this does not fix it. They have been disabled already some time ago.
     
  5. Jesse Norell

    Jesse Norell ISPConfig Developer ISPConfig Developer

    Do you have monit installed?
     
    till and edge like this.
  6. edge

    edge Active Member Moderator

    Yes. Monit is installed. Monitoring postfix, mysqld and amavisd (because of other problems.).
    I guess. monit could trigger this error... hmmmmm
     
  7. edge

    edge Active Member Moderator

    Okay. This problem is found and fixed. The MySQL monitor script for monit had a small error in it. Oooops...
    Thank you Jesse.... Now... Next problem.. Soon a new post about this from me.
     
    Th0m and till like this.

Share This Page