[FIXED] postfix - cannot send emails to some accounts

Discussion in 'Server Operation' started by Neptun, Jul 24, 2019.

Tags:
  1. Neptun

    Neptun Member

    Hi all,
    i have an issue to send emails to some accounts - i have found this in the logfiles:

    Code:
    Jul 24 12:52:36 server0101 postfix/smtp[27874]: E8ADA296675: to=<[email protected]>, relay=account.com-com.mail.protection.outlook.com[104.47.0.36]:25, delay=1.3, delays=0.02/0.03/0.34/0.96, dsn=2.6.0, status=sent (250 2.6.0 <[email protected]> [InternalId=17867063958582, Hostname=VI1PR02MB4957.eurprd02.prod.outlook.com] 11103 bytes in 0.295, 36.652 KB/sec Queued mail for delivery)
    Jul 24 12:52:36 server0101 postfix/qmgr[14614]: E8ADA296675: removed
    Receive an email from this account - no problem - but not possible to send a new mail or reply to an existing
    How can i fix this issue ?

    Thanks
     
  2. ahrasis

    ahrasis Well-Known Member

    Meaning some did go through, right?

    Is your mail server ssl certs issued by Let's Encrypt or self-signed?
     
  3. Neptun

    Neptun Member

    i have now an 2nd issue found:

    Code:
    Jul 24 13:47:01 server0101 postfix/smtp[31067]: 27286296282: to=<[email protected]>, relay=127.0.0.1[127.0.0.1]:10026, delay=300, delays=0.28/0.03/0/300, dsn=4.4.2, status=deferred (conversation with 127.0.0.1[127.0.0.1] timed out while sending RCPT TO)
    Code:
    -Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
    27286296282 857 Wed Jul 24 13:42:01 [email protected]
    (conversation with 127.0.0.1[127.0.0.1] timed out while sending RCPT TO)
    [email protected]
    
    -- 0 Kbytes in 1 Request.
    i have tried to send this from my mobile phone with the new server account


    i have received an email from this account - but i cannot send something there - correct
    my mail server use ssl certs issued by Let's Encrypt

    here is now also:
    Code:
    Jul 24 13:58:39 server0101 postfix/smtp[31972]: 45C2D296675: to=<[email protected]>, relay=127.0.0.1[127.0.0.1]:10026, delay=0.63, delays=0.24/0.03/0.01/0.35, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10027): 250 2.0.0 Ok: queued as C836C296684)
    Jul 24 13:58:39 server0101 postfix/qmgr[14614]: 45C2D296675: removed
    this additional entries are now in the email logfile too:

    Code:
    Jul 24 14:19:42 server0101 postfix/qmgr[14614]: C55F9296675: from=<[email protected]>, size=2036, nrcpt=1 (queue active)
    Jul 24 14:19:42 server0101 amavis[31944]: (31944-02) Passed CLEAN {RelayedOutbound}, ORIGINATING LOCAL [33.144.212.61]:32183 [33.144.212.61] <[email protected]> -> <[email protected]>, Queue-ID: 27286296282, Message-ID: <-6o4usz6fetpy8wta72gkh3i7-6zh9r-dnqntny8c4kh3i9tvi3idsxv6vcu2e-tn7gs2uya2in-jevk6npi81mp-is07s3edk4sa[email protected]email.android.com>, mail_id: lo_cZ8syLHEx, Hits: 0.741, size: 856, queued_as: C55F9296675, dkim_new=default:myserver.eu, 15363 ms
    Jul 24 14:19:42 server0101 postfix/smtp[937]: 27286296282: to=<[email protected]>, relay=127.0.0.1[127.0.0.1]:10026, delay=2262, delays=2246/0.05/0.01/15, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10027): 250 2.0.0 Ok: queued as C55F9296675)
    Jul 24 14:19:42 server0101 postfix/qmgr[14614]: 27286296282: removed
    Jul 24 14:19:43 server0101 postfix/smtp[944]: C55F9296675: to=<[email protected]>, relay=eur.olc.protection.outlook.com[104.47.9.33]:25, delay=0.7, delays=0.03/0.02/0.14/0.5, dsn=2.6.0, status=sent (250 2.6.0 <-6o4usz6fetpy8wta72gkh3i7-6zh9r-dnqntny8c4kh3i9tvi3idsxv6vcu2e-tn7gs2uya2in-jevk6npi81mp-is07s3edk4sa[email protected]email.android.com> [InternalId=56178172281172, Hostname=VE1EUR03HT207.eop-EUR03.prod.protection.outlook.com] 8919 bytes in 0.312, 27.866 KB/sec Queued mail for delivery -> 250 2.1.5)
    Jul 24 14:19:43 server0101 postfix/qmgr[14614]: C55F9296675: removed
     
    Last edited: Jul 24, 2019
  4. ahrasis

    ahrasis Well-Known Member

    Which cannot send emails, your mail server to others or others to your mail server? Is your port 25 on your mail server open for both inbound and outbound?
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    The log you posted above shows that an email has been delivered successfully to [email protected]. If the mail did not show up in the recipient account, then live.at must have dropped it internally after they accepted the email. This happens sometimes when you do test emails especially when they contain unnatural text or something like test in the subject, then outlook might see them as spam and drops them. So thats not a problem of your server.
     
  6. Neptun

    Neptun Member

    You are right - this mail to the outlook live (hotmail/live msn) account is now delivered and was received as spam.

    But the other email is nowhere - the account of this mail server is handled by Microsoft exchange server/cloud of outlook 365 - i receive from there within 5 seconds the mail at my server - but to send something is impossible - i have also tried now from my android smartphone - no error message back nothing - only lost

    I have also tried to send the mail with & without ssl/tls - no idea where the problem could happen
    I use also dkim - does this cause any issue ?

    Thanks
     
  7. Neptun

    Neptun Member

    I have done yesterday a complete fresh setup of the server - but today same issue - not possible to send an email to the account of the Microsoft exchange server/cloud of outlook 365

    To receive an email from there - without any issue - but no new mail or a reply of the received mail from there is not possible

    Code:
    Jul 25 13:35:53 server0101 postfix/smtp[8427]: C95E634E92D: to=<[email protected]>, relay=company-com.mail.protection.outlook.com[104.47.2.36]:25, delay=1.5, delays=0.01/0.03/0.35/1.1, dsn=2.6.0, status=sent (250 2.6.0 <[email protected]> [InternalId=14946486194968, Hostname=VI1PR02MB4960.eurprd02.prod.outlook.com] 10414 bytes in 0.295, 34.400 KB/sec Queued mail for delivery)
    Jul 25 13:35:53 server0101 postfix/qmgr[29770]: C95E634E92D: removed
    Code:
    Jul 25 13:38:04 server0101 postfix/cleanup[8501]: 80DDF34E92B: message-id=<[email protected]od.outlook.com>
    
    Jul 25 13:38:04 server0101 postfix/qmgr[29770]: 80DDF34E92B: from=<[email protected]>, size=121880, nrcpt=1 (queue active)
    Jul 25 13:38:04 server0101 amavis[9997]: (09997-02) Passed CLEAN {RelayedInbound}, [40.107.8.130]:42981 [20.178.13.78] <[email protected]> -> <[email protected]>, Queue-ID: C2D0734E92A, Message-ID: <[email protected]od.outlook.com>, mail_id: w0PSn8pVx5DL, Hits: 0.002, size: 121212, queued_as: 80DDF34E92B, dkim_sd=selector2-group-onmicrosoft-com:group.onmicrosoft.com, 655 ms
    Jul 25 13:38:04 server0101 postfix/smtp[8502]: C2D0734E92A: to=<[email protected]>, relay=127.0.0.1[127.0.0.1]:10024, delay=1, delays=0.31/0.04/0/0.66, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as 80DDF34E92B)
    Jul 25 13:38:04 server0101 postfix/qmgr[29770]: C2D0734E92A: removed
    Jul 25 13:38:04 server0101 dovecot: lda([email protected])<8507><6R5TJJyUOV07IQAA12eN7Q>: sieve: msgid=? <[email protected]od.outlook.com>: stored mail into mailbox 'INBOX'
    Jul 25 13:38:04 server0101 postfix/pipe[8506]: 80DDF34E92B: to=<[email protected]>, relay=dovecot, delay=0.11, delays=0.01/0.03/0/0.07, dsn=2.0.0, status=sent (delivered via dovecot service (lda([email protected],)Error: net_connect_unix(/var/run/dovecot/stats-writer) failed: Permission den))
    Jul 25 13:38:04 server0101 postfix/qmgr[29770]: 80DDF34E92B: removed
    I have also tried with DKIM active and with DKIM disable - has this any effect normally?

    Thanks for your help how can this problem be fixed
     
    Last edited: Jul 25, 2019
  8. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Try this:
    https://www.mail-tester.com/
    When you get an error message in log, use Internet Search Engines with that error message text.
    Code:
    Error: net_connect_unix(/var/run/dovecot/stats-writer) failed: Permission den)) 
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    That's to be expected as there was no problem on your server. I explained already in #5 that the email was delivered successfully and when Microsoft decides to drop it, then that's a decision by their mail filters. Contact Microsoft support, there is a complaint form for such cases.
     
  10. Neptun

    Neptun Member

    I have found a fix for the issue - change/additional settings in dovecot config file fixed everything - now everything perfect working
     
    Last edited: Jul 26, 2019
  11. macguru

    macguru Member HowtoForge Supporter

    Hi, Neptun,

    I'm occasionally have same issue with e-mail sent to protected.outlook.com.
    Can you please share what you have changed in settings?
    Thanks in advance.
     

Share This Page