FIXED Debian fresh install - can't send emails

Discussion in 'Server Operation' started by LIJE, Aug 24, 2018.

  1. LIJE

    LIJE Member

    Hi,

    first of all, I followed this howto: https://www.howtoforge.com/tutorial...-9-stretch-apache-bind-dovecot-ispconfig-3-1/
    I installed about 50 websites and then I noticed the emails are not working. I can see them in the queue but nothing comes out.
    When I do a postqueue -p, I notice there are some messages: (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)

    I got nothing in logs. No error messages. Any clue ?

    [email protected]:~# dpkg -S `which sendmail`
    postfix: /usr/sbin/sendmail


    [email protected]:~# postqueue -f
    postqueue: fatal: Cannot flush mail queue - mail system is down


    [email protected]:~# service amavis status
    ● amavis.service - LSB: Starts amavisd-new mailfilter
    Loaded: loaded (/etc/init.d/amavis; generated; vendor preset: enabled)
    Active: active (running) since Fri 2018-08-24 16:21:05 UTC; 9min ago
    [...] 451 4.3.0 Error: queue file write error

    [email protected]:~# service clamav-daemon status
    ● clamav-daemon.service - Clam AntiVirus userspace daemon
    Loaded: loaded (/lib/systemd/system/clamav-daemon.service; enabled; vendor preset: enabled)
    Drop-In: /etc/systemd/system/clamav-daemon.service.d
    └─extend.conf
    Active: active (running) since Fri 2018-08-24 16:20:52 UTC; 10min ago

    [email protected]:~# service postfix status
    ● postfix.service - Postfix Mail Transport Agent
    Loaded: loaded (/lib/systemd/system/postfix.service; enabled; vendor preset: enabled)
    Active: active (exited) since Fri 2018-08-24 16:32:16 UTC; 2s ago
    Process: 6132 ExecStart=/bin/true (code=exited, status=0/SUCCESS)
    Main PID: 6132 (code=exited, status=0/SUCCESS)
     
  2. LIJE

    LIJE Member

    FIXED.

    postfix-mysql was missing and a misconfiguration of the master.cf
     

Share This Page