First Time using Virtual Hosts and BIND

Discussion in 'Installation/Configuration' started by martinvidic, Jan 23, 2012.

  1. martinvidic

    martinvidic New Member

    Hi Everybody :)
    I'm new here - And new to dedicated hosting.
    Last week I learned a lot about ssh, apache, etc, and my hosting provider promised he would help me set up my domain so that it works as home/

    Unfortunately it looks like the know less than I :(
    I had to fix their mistakes in named.conf so that I can even start bind.

    I'm using webmin and terminal to set things up.
    It looks like bind is running now and i also added a virtual host in httpd.conf.
    However, it's still not working. In webmin I don't have the appache webserver option , dont know why.

    So this is what i did so far:
    Can anybody help me with this?
    this is my bind zone:

    $TTL 180
    @      86400    IN      SOA [email protected] (
                    2008021501      ; serial, todays date+todays
                    86400           ; refresh, seconds
                    7200            ; retry, seconds
                    3600000         ; expire, seconds
                    86400 )         ; minimum, seconds 86400 IN NS 86400 IN NS
    ns1                     IN A
    ns2                     IN A IN A IN A
    And this is etc/httpd/conf/httpd.conf
    NameVirtualHost *:80
    <VirtualHost *:80>
        ServerAdmin [email protected]
        DocumentRoot /home/
        ErrorLog logs/
        CustomLog logs/ common
    When I type, nothing happens
  2. visjusz

    visjusz New Member

    Domain configuration is ok:

    You have problem with bind:
    zone "" {
            type master;
            allow-transfer {none;};
            file "/etc/bind/";
    $TTL        3600
    @       IN      SOA (
                            2012012301       ; serial, todays date + todays serial #
                            7200              ; refresh, seconds
                            540              ; retry, seconds
                            604800              ; expire, seconds
                            86400 )            ; minimum, seconds
    ; 3600 A 3600      MX    10 3600      NS 3600      NS
    mail 3600 A
    www 3600 A
    AND run:
    /etc/init.d/bind9 restart

    then tell is working or not;)
  3. martinvidic

    martinvidic New Member

    Thanx, but i was asked for ns1 and ns2 IP addresses now.

    So i reinstalled bind and now i see pre-existing zones:
    Root Zone

    I can't add a new master zone with webmin - because if I try, all the above zones create errors. so i guess its a problem with webmin. I also tried to delete the above zones.
    This time I just edited the named.conf file and through ssh. I can start bind now, but when i try to apply my zone through webmin, I get:
    NDC command failed : rndc: connect failed: connection refused
  4. martinvidic

    martinvidic New Member

    The whole named.conf looks like this:

    // named.conf
    // Provided by Red Hat bind package to configure the ISC BIND named(8) DNS
    // server as a caching only nameserver (as a localhost DNS resolver only).
    // See /usr/share/doc/bind*/sample/ for example named configuration files.

    options {
    listen-on port 53 {; };
    listen-on-v6 port 53 { ::1; };
    directory "/var/named";
    dump-file "/var/named/data/cache_dump.db";
    statistics-file "/var/named/data/named_stats.txt";
    memstatistics-file "/var/named/data/named_mem_stats.txt";
    allow-query { localhost; };
    recursion yes;

    dnssec-enable yes;
    dnssec-validation yes;
    dnssec-lookaside auto;

    /* Path to ISC DLV key */
    bindkeys-file "/etc/named.iscdlv.key";

    logging {
    channel default_debug {
    file "data/";
    severity dynamic;

    zone "." IN {
    type hint;
    file "";

    include "/etc/named.rfc1912.zones";

    zone "" {
    type master;
    allow-transfer {none;};
    file "/var/named/";
  5. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    ls -la /etc/bind/

Share This Page