First time server effort

Discussion in 'HOWTO-Related Questions' started by struggling, Nov 17, 2009.

  1. struggling

    struggling New Member

    Re: http://www.howtoforge.com/set-up-ubuntu-server-with-ehcp-lamp-dns-ftp-mail-p2
    Very happy to find this helpful site. I am not totally new to Linux, but am new to servers. I am trying to set up a LAMP server, and find myself stymied even though I chose the easiest looking tutorial!
    I have spent some time looking at what my Netgear router lets me do, and checking my settings.
    I am able to use port forwarding, so I set it up on the computer I want to be a server. This computer has IP on my LAN of 192.168.1.5
    I initially installed the LAMP server using dhcp
    I believe I still need to set a static IP address, is that right? If not I guess it might be easier.
    On page 2 of the howto /etc/network/interfaces is edited to be static, not dhcp, and address, netmask, network, broadcast and gateway IP addresses are entered. I was confused by some of these. I used ipconfig in windows and my router's webpage to find all the details I could, but they are sometimes confusing to a newbie. I assume IP address is 192.168.1.5, netmask is the LAN port subnet mask reported by Netgear as 255.255.255.0, network is 192.168.1.0 (guessing really, don't know how to figure that), broadcast? can't even guess, gateway seems from ipconfig to be 192.168.1.1
    My nameserver was 192.168.1.1 as written in the tut from /etc/resolv.conf
    After all this is solved, I don't kow what domain name I can use, as I do not have a domain name and I don't intend to use this as a mail server. I do want to be able to "see" the server on the web to show that it is "working"!
    Sorry this is long and maybe dumb to some of you, thanks for any help.
    Finally, it looks as though I could set up my router to use a static address, if that would help. I am using Ubuntu 9.10 32bit server
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Broadcast probably is 192.168.1.255. The other values seem to be correct.


    You can get a hostname from dyndns.org.
     
  3. struggling

    struggling New Member

    Thanks very much falko. I pressed on with the setup until I hit some apparent snags.
    I went to dyndns.org and got a free hostname.
    I edited /etc/network/interfaces as suggested.
    I downloaded and installed ehcp.
    I didn't really want to install a mail server but that was in the tut and I assumed I needed to in order to host a webpage, so I did the postfix configuration. I got confused here. My hostname is maxdata01, my domain name is homelinux.org. The postfix configuration program put my system mail name as maxdata01, but I thought this was wrong and put homelinux.org (after much thought).
    I went on with configuring phpmyadmin for apache2 , then I got another screen "configuring phpmyadmin". Perhaps this is because I installed more server features to start with. That seemed to go OK at the time.
    Meanwhile I had also downloaded ddclient from dyndns.org, installed it and fixed the ddclient.conf file according to the recommendation of dyndns.org.
    So when I finished configuring ehcp I thought everything was done.
    When I tried to login using http://maxdata01.homelinux.org I got a page come up telling me that it was the default ehcp page and I should setup / add my domain. [Again I was a bit confused what to enter but thought it was homelinux.org] I tried to do that but it doesn't seem to have changed anything for the better - some things I tried made an "Under construction" page come up. I also had a warning when I got inside ehcp that I was giving the IP address of the individual computer I was using for the server not the routers IP. So I changed that but it didn't help (except taking away the warning). I had set up port forwarding on the router so I didn't think this mattered. Then I read something about checking MySQL was working so I tried to login to phpMyadmin, but the password I had set did not work, perhaps because I set up LAMP before ehcp?
    I am pretty confused by all of this. I thought I was very close to making it work. Maybe I will start again, and do exactly what was done in the tut, instead of installing LAMP first.
    Sorry for the long post.
    From my last post, how was I supposed to work out "broadcast" and "network" IP addresses? I did try to do so but I could not figure it out.
     

Share This Page