first time around, ssl question

Discussion in 'Installation/Configuration' started by quinohe, Nov 7, 2010.

  1. quinohe

    quinohe New Member

    Dear devs,

    First of all thanks for your beautiful website and support by making manuals and ispconfig. This is my first post, but I'm lurking fore some time now and Howtoforge is in my opinion one of the nicest places to 'hang out' and build.
    I found this place because I like Linux and use Fedora as my main os for a year now, fully desktop. Well without tweaking you get nowhere, now thats where you guys get in the picture. ;)
    I did education mcsa, but my hart is whit linux.
    The first 'real server' ('*'mean not windows) I build was made whit the guide debian etch multiserver setup, I did this one whit Lenny, did that with Virtualbox on Fedora (after 2 setups worked like a charm)
    Well after that I wanted a new challenge, I'm already using virtual machines for say 6 years now, but always the GUI ones.
    Than I found your guides of Openvz en Webvz.
    So I have this old Compaq deskpro with pIII 800Mhz. 512sdram 160GB HD
    I mannaged to install openvz with webvz en 14 servers running under Ispconfig, everyting not fully worked, like Cups and Jinzora but all servers were up and running! :)
    Well, I think that really is a succes, but only because of your good tutorials and the help of Google. Really some of the kudos are 4 google! Without them in the first place, I would have never found you guys!
    I still create my virtual machines on the laptop (virtualbox) and than SSh the hole machine into a openvz container on the compaq deskpro, beautiful way of creating by the way!
    Ispconfig I think is a really nice tool, and not only for a server forest, but also for the hobby people like me. Updating becomes feasting, and I saw your new version has beancounters, or they were there all along and I never found them.
    Now, I told you something about me, I also want to know something.
    Bey the way, I really need a copy of that new guide you made, but no paypal and so on! :(
    I installed a fresh copy of your new version of Ispconfig 3.0.3.
    This one gives the possibility of creating a https by creating a self signed certificate, which I did.
    When I create the next server and install Ispconfig by filling out that form, it will not find the master.
    How do I tackle this issue, I already know I have to put the certificate on the next one.
    Well I did google on that one for a few days now, but I don't see a sollution.
    Would you be so kind and guide me trough this one, some how.

    Thanks
    Quinohe
     
    Last edited: Nov 7, 2010
  2. falko

    falko Super Moderator ISPConfig Developer

    You can buy a HowtoForge subscription ( http://www.howtoforge.com/subscription ), it can be payed through WorldPay if PayPal isn't available.

    Do you have any error messages that you can post here?
     
  3. quinohe

    quinohe New Member

    Yes, I did see!, but I only have a bank account so this will probably not work.
    Isn't it possible to do a monthly pay by bank?
    Well no, in fact there is none during creating the master, it creates a 4096 bit
    self signed certificate.
    When ready I stop all services not needed than ssh the thing into a container,
    perform all necessary commands and symlinks.
    Shutdown the virtualbox on which the machine was created, start the container and from now on is reachable.
    Now I create the second server in Virtualbox, start Ispconfig install program which runs fine.
    But when I come to the step where I tell it to look for the master it just won't find it, over and over, I did the same without cert., and that went alright!
    So the only thing goes wrong is it gets in a loop, its about this part;

    Code:
    MySQL master server hostname []: <-- web.example.tld
    MySQL master server root username [root]: <-- root
    MySQL master server root password []: <-- Enter the root password of the master server here
    MySQL master server database name [dbispconfig]: <-- dbispconfig 
    Now I'm a newbie in Linux server country, so if it is something I should have known, my bad. But, I like to make this work.
    At the moment I,m still localdomain, but I will go outside with it when I master it a little bit more.
    By the way all machines made are Debian lenny 5.06.

    Quinohe
     
    Last edited: Nov 8, 2010
  4. falko

    falko Super Moderator ISPConfig Developer

    If you can't use PayPal and WorldPay doesn't offer you the possibility to pay through your bank account, then this is not possible. :( Till might be able to help you, but he's not available right now (he'll be back in the office on November 22).


    Does a MySQL connection on the command line work?
    Code:
    mysql -h web.example.tld -u root -p
     
  5. quinohe

    quinohe New Member

    Hi Falko,

    Thanks for answering so far.

    No problem at all, I will wait until then. :)
    Yes, I get an error on both master and slave!
    Code:
    ERROR 2003 (HY000) : Can't connect to MySQL server on 'web.example.tld' (110)
    web.example.tld is the master!
    I did google on this one for a while, but there were so many different answers that I will wait for yours.
    Pinging works fine both ways!
    Thanks
    Quinohe

    P.s.
    Thanks for activating my account!
    Because you had to do by hand!
     
    Last edited: Nov 10, 2010
  6. falko

    falko Super Moderator ISPConfig Developer

    Can you post the outputs of
    Code:
    netstat -tap
    and
    Code:
    iptables -L
    from the master?
     
  7. quinohe

    quinohe New Member

    Code:
    server:~# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 *:mysql                 *:*                     LISTEN      409/mysqld      
    tcp        0      0 *:sunrpc                *:*                     LISTEN      242/portmap     
    tcp        0      0 *:http-alt              *:*                     LISTEN      829/apache2     
    tcp        0      0 *:www                   *:*                     LISTEN      829/apache2     
    tcp        0      0 *:tproxy                *:*                     LISTEN      829/apache2     
    tcp        0      0 *:47124                 *:*                     LISTEN      248/rpc.statd   
    tcp        0      0 *:ssh                   *:*                     LISTEN      337/sshd        
    tcp        0      0 localhost.localdom:smtp *:*                     LISTEN      754/exim4       
    tcp        0      0 *:https                 *:*                     LISTEN      829/apache2     
    tcp        0      0 192.168.1.151:ssh       192.168.1.239:35209     ESTABLISHED 4839/0          
    tcp6       0      0 [::]:ssh                [::]:*                  LISTEN      337/sshd
    This seems to be alright
    Code:
    server:~# iptables -L
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination         
    FATAL: Could not load /lib/modules/2.6.26-2-openvz-686/modules.dep: No such file or directory
    FATAL: Could not load /lib/modules/2.6.26-2-openvz-686/modules.dep: No such file or directory
    fail2ban-ssh  tcp  --  anywhere             anywhere            multiport dports ssh 
    
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination         
    
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination         
    
    Chain fail2ban-ssh (1 references)
    target     prot opt source               destination         
    RETURN     all  --  anywhere             anywhere
    Hmzz, looks like I have a fatal, don't know if thats it, but will try and find some things out.
    Quinohe
     
  8. quinohe

    quinohe New Member

    ok let's fanisch the fatal;
    Code:
    mkdir -p /lib/modules/2.6.26-2-openvz-686
    depmod -a
    it looks like this
    Code:
    :~# iptables -L
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination         
    fail2ban-ssh  tcp  --  anywhere             anywhere            multiport dports ssh 
    
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination         
    
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination         
    
    Chain fail2ban-ssh (1 references)
    target     prot opt source               destination         
    RETURN     all  --  anywhere             anywhere  
    Quinohe
     
  9. quinohe

    quinohe New Member

    All this work for nothing!
    Not all, I learned something, like reading.
    There was nothing wrong at all, but I guess you saw that before I did!
    I made my own 'perfect server setup' in a file, with help from your guides.
    But a while ago I used another hosts file, thats where it went wrong.
    Instead of using 168.1, I was using 168.3, damn I feel stupid.
    Well, the first slave now is ssh'd into the VE. :eek:
    It already finished without error. (only the usual).

    Thanks for your time Falko:)
    Quinohe
     
    Last edited: Nov 12, 2010

Share This Page