Firewall Setup With Free Chat & Voice Comm Server

Discussion in 'Installation/Configuration' started by ricardohf, Mar 10, 2008.

  1. ricardohf

    ricardohf New Member

    Dear friends,

    I am a network system administrator and I use Kernel 2.6 and iptables as a firewall and NAT. My company decided to install a Windows application called CYF (CALL YOU FREE) in all the desktops of the customer support and sales department. CALL YOU FREE is a communications application to answer incoming webcalls and chat contacts from our company’s website and we are using its freeware version.

    The issue is that when I tested the application with my computer connected directly to the internet (public IP) it works fine. But when I connected my computer in a private IP behind the NAT I cannot even login to the system.

    I conclude that there must be a firewall problem, so I opened all ports in the firewall and it works fine.

    I would like to know how I can find out what port(s) does the application try to access. It seems to be an Asterisk based application using IAX protocol so I tried opening port 4569 but nothing happened.

    I would appreciate your help because I really don’t know how to find out what port should I open, unless I try one by one, or it may use yet more than one port.

    Thanks,
    Ricardo Houssef.
     
  2. topdog

    topdog Active Member HowtoForge Supporter

    You can use tcpdump to see what ports the client is connecting to, better still you can as the vendor what ports need to be open for the application to function. Some protocols require special NAT helper modules sip,tftp,h323 and pptp are examples of these
     
  3. ricardohf

    ricardohf New Member

    Topdog, thanks for your answer. I downloaded it directly from the developer of the software (www.cyf.com). I am using the freeware version, which doesn´t have support. Anyway they answer me telling that port 80 UDP must be opened.

    I tried opening that port and it´s working fine now. I recommend it.

    Thanks anyway for the tip. I will also use tcpdump to leran more about how the software works.

    Ricardo
     
  4. mcomotti

    mcomotti New Member

    This may help too. I tried to run the “cyf.exe” on a Windows Vista and it didn’t run because of permission problems, but It run well as administrator (right button on the program icon and click “run as administrator”).

    Note that only the application has to be run as administrator, not the webphone.
     

Share This Page