Firewall fails to start after reboot

Discussion in 'Installation/Configuration' started by wpwood3, Apr 2, 2010.

  1. wpwood3

    wpwood3 New Member

    Everytime I reboot, the firewall is down when the system comes up.

    If I deactivate the firewall in ISPConfig3 and then reactivate it, iptables -L shows the firewall to be working. But, if I reboot, I get the following when I check iptables:

    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination
    fail2ban-SSH  tcp  --  anywhere             anywhere            tcp dpt:ssh
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination
    Chain fail2ban-SSH (1 references)
    target     prot opt source               destination
    RETURN     all  --  anywhere             anywhere
    Doesn't ISPConfig3 do a chkconfig for bastille-firewall when it is installed? I see /etc/rc.d/init.d/bastille-firewall but there's no sign of bastille-firewall in any of the run levels (rc0.d-rc6.d)
    [[email protected] ~]# chkconfig --list bastille-firewall
    service bastille-firewall supports chkconfig, but is not referenced in any runlevel (run 'chkconfig --add bastille-firewall')
    Last edited: Apr 2, 2010
  2. Mark_NL

    Mark_NL New Member

    Looks like the init script doesn't have runlevel entries ..

    chkconfig bastille-firewall on
    does that work?
  3. wpwood3

    wpwood3 New Member

    Thanks for your reply. Sure that works and so does 'chkconfig --add bastille-firewall' but, that's not really my question.

    I was trying to understand why the runlevel entries are missing in the first place. I think the problem is that the step to create the needed run levels is missing from the Perfect Server Howto. I was confused if this was a bug in the ISPConfig3 install or just a missing step in the Howto.
  4. nikopol

    nikopol New Member

    I was running in the same problem and figured out that after an upgrade of the ISPconfig version the firewall was disabled in the web gui.

    I switched it on and everything was working fine again also with a running fail2ban configuration.

Share This Page