Firefox hangs accessing control panel in https

Discussion in 'Installation/Configuration' started by ADM, Apr 18, 2007.

  1. ADM

    ADM ISPConfig Developer ISPConfig Developer

    I have Firefox browser that hangs while accessing the control panel using https

    The same control panel works using IE.

    I noticed this inside /root/ispconfig/httpd/logs/error_log
    Code:
    [Fri Apr  6 19:58:22 2007] [error] mod_ssl: SSL handshake failed: HTTP spoken on HTTPS port; trying to send HTML error page (OpenSSL library error follows)
    [Fri Apr  6 19:58:22 2007] [error] OpenSSL: error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request [Hint: speaking HTTP to HTTPS port!?]
    
    ISPConfig Version: 2.2.11
    Successfully installed on Debian v4.0rc2 (etch)


    Any hint will be appreciated.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Have you tried both http and https? Which protocol did you choose during ISPConfig installation?
     
  3. ADM

    ADM ISPConfig Developer ISPConfig Developer

    Hi falko,

    Thanks for your reply.

    No, I haven't tried in http because I think it will works, do you fast some fast steps to try http?

    I need that it works in https. It seems that Firefox starts talking https and at some point starts talking in http, but this is strange because the same url works with IE and we know that IE is really more buggy than FF.

    What should I try?
     
  4. falko

    falko Super Moderator ISPConfig Developer

    In this case you can try to recreate the SSL certificate as shown in post #4 on http://www.howtoforge.com/forums/showthread.php?t=121
     

Share This Page