Firefox and flash player issue!

Discussion in 'Installation/Configuration' started by mrwasabi, Dec 18, 2007.

  1. mrwasabi

    mrwasabi New Member

    Hello folks,
    I've recently upgraded to Ubuntu 7.1, ran all the required updates, Ubuntu restricted and so forth, and I cannot view flash websites! I've tried reinstalling flash and it does no good, any ideas why this is happening? TIA

    BTW the same thing happens with Opera, flash will not work.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Please type
    Code:
    about:plugins
    in the address bar of Firefox. IS the Flash Player listed in the list of plugins that appears?
     
  3. mrwasabi

    mrwasabi New Member

    Flash and Firefox

    Ok I determined that it was the flash player in the repo that was the problem, it's a bad version! I removed flash first of all:
    sudo apt-get remove flashplugin-nonfree gnash

    Then I downloaded a different flash player:
    http://fpdownload.macromedia.com/get/flashplayer/installers/archive/fp9_archive.zip

    I unzipped the archive:
    tar -zxvf install_flash_player_9_linux.tar.gz
    Or simply right click the archive in the folder where you downloaded it and select "extract", then point it to the folder where you wish to save it.

    Then I installed the new version of flash player by simply navigating to the correct folder, there are several versions in this archive so select the appropriate one for your OS.
    I saved mine in the documents folder, 9r48 is for linux: /documents/fp9_archive/9r48/install_flash_player_9_linux
    sudo ./flashplayer-installer
    You'll be asked for the install path, for firefox it's:
    /usr/lib/firefox/

    Then I launched firefox and flash now works!
     
  4. textonyx

    textonyx New Member

    Flash and Firefox

    Hi,
    I intended just to drop falko a line thanking him for the work he did on the
    tutorial, especially providing all those time-consuming pictures. VMware and
    f-stop were also on the list of packages to install and I wanted to learn how
    to use them. I had just tried out Kubuntu and it took me 35 minutes to install
    Flash, so I was looking for an easier approach than having to enable the
    multiverse repository. Thanks also for the VMware pointer on tut. page 5.

    I went to the Macromedia website and downloaded the current flash*tar.gz
    which I unpacked in /home/ubuntu/downloads into the same directories that
    mrwasabi recounted for Flash. I ran flash-install from the command line which
    I thought would be the same as terminal, but it didn't work until I switched
    to terminal which was available in the command line option window. I saw it
    install although as I didn't use sudo it just installed for the user logged in, me.
    When I went back to the Macromedia site with Firefox (which was easy to
    install) flash and sound just worked without any more ado. Thanks for the

    Tutorial,
    Techtonics
     

Share This Page