Finished Perfect setup 10.2 but now...

Discussion in 'Server Operation' started by SkykerZio, Nov 4, 2007.

  1. SkykerZio

    SkykerZio New Member

    Everything installed (finally) and I've reached the end of the walkthrough.
    Thanks falko!

    I installed the optional component ISPConfig, But did not take SuExec yet.

    the error im getting on boot is

    "Starting httpd2 (pitchfork) (98) Address is already in use: make_sock: could not bind to address [::]:80
    (98) address already in use :make_sock: could not bind to address 0.0.0.0:80
    no listening sockets available, shutting down
    unable to open logs

    startproc:exit status of parent of /usr/sbin/httpd2-prefork: 1"

    So this means I need to change my listening IP right?

    how do I do that?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The error means, that there is already a program (possibly a webserver) started on port 80. Please post the output of:

    netstat -tap
     
  3. SkykerZio

    SkykerZio New Member

    well...theres alot of typing and wlaking back and forth across the room involved in that... are you looking for a specific line?

    I noticed 2 different entries that say:

    localhost:953 3954/named

    ill post the rest of it later

    EDIT:

    ok I found this command

    netstat -lnp | grep ':80'

    and got

    tcp 0 0 :::80 LISTEN 3678/httpd-prefork

    so I also ran

    netstat -lnp | grep ':81'

    and got

    tcp 0 0 0.0.0.0:81 0.0.0.0:* LISTEN 3576/ispconfig_http
     
    Last edited: Nov 5, 2007
  4. falko

    falko Super Moderator ISPConfig Developer

    Take a look at your Apache configuration (I think it's somewhere in /etc/httpd on SUSE). There must be a Listen line somewhere. How exactly does it look?
     
  5. SkykerZio

    SkykerZio New Member

    yeah Its in /etc/apache2/

    There are two lines that have listen:


    listen 80

    and listen 443

    i dont have a /etc/httpd

    UPDATE:

    ok i changed the first "listen 80" line to "listen 192.168.1.2:80"

    and that solved the error but localhost/127.0.0.1 still doesnt work.
    I tried 192.168.1.2 in my browser and I got

    "Access forbidden!
    You don't have permission to access the requested directory. There is either no index document or the directory is read-protected.

    If you think this is a server error, please contact the webmaster.

    Error 403
    192.168.1.2
    Tue Nov 6 22:55:32 2007
    Apache/2.2.3 (Linux/SUSE)"

    im looking for where My index.html file should be to see if its there, to eliminate that possible problem.

    in looking at my httpd.conf file I noticed:

    # forbid access to entire file system by default
    <Directory />
    Options None
    Allowoverride None
    Order deny,allow
    Deny from all
    </Directory>

    and Im about to try commenting this out, will update after restart and test
     
    Last edited: Nov 7, 2007
  6. falko

    falko Super Moderator ISPConfig Developer

    Add another Listen line:
    Code:
    Listen 127.0.0.1:80
    and restart Apache.

    I think the default document root for SUSE is /srv/www/html or /srv/www/htdocs or just /srv/www, so you must place your index.html there.
     

Share This Page