filter was not added: PHP error

Discussion in 'Installation/Configuration' started by gilas, Jun 8, 2006.

  1. bionictrout

    bionictrout New Member

    Same problem... fix doesn't work...

    I have ISPConfig installed on OpenSUSE 10.2 and am having the same issue.

    I made the change indicated above, made a change to a value of the website using the control panel, and even rebooted the entire server. I still have the same issue.

    I get the same error in my Apache error log as everyone else:

    "[error] an unknown filter was not added: PHP"

    Anyone else figured this out yet? Is this a problem only with OpenSUSE 10.2, or will I have similar issues with other distro's?

    Thanks.
     
  2. till

    till Super Moderator

    Do you have copies of the file Vhost_ispconfig.conf with a date appended to the filename? Then have a look here:

    http://www.howtoforge.com/forums/showthread.php?t=13596

    This is a SuSe specific setting, but not a problem as the solution has been described in this thread works definately.
     
  3. bionictrout

    bionictrout New Member

    No, all I have is this:

    web01:/etc/apache2/vhosts # ll
    total 8
    -rw-r--r-- 1 root root 1346 Aug 20 10:11 Vhosts_ispconfig.conf
    -rw-r--r-- 1 root root 1346 Aug 20 10:11 Vhosts_ispconfig.conf~
     
  4. till

    till Super Moderator

    Then login to the ispconfig interface, edit a setting in one of your websites, e.g. the quota setting and click on the save button.

    update:

    ok, I missed that you use suse 10.2, for suse you will have to choose addhandler instead of addtype in config.inc.php. This is decribed in config.inc.php.
     
    Last edited: Aug 20, 2007
  5. bionictrout

    bionictrout New Member

    Done... Still have the same problem.

    Here is the line I changed in /home/admispconfig/ispconfig/lib/config.inc.php:

    $go_info["server"]["apache2_php"] = 'addtype'; // 'filter' = set PHP filters, 'addtype' = Set PHP addtype or 'both' = Set Filter + Addtype, suphp = SuPHP wrapper enabled, 'addhandler' = Set PHP AddHandler (nescessary for SuSE 10.2)

    (I have tried both 'addtype' and 'addhandler'. Both yield the same problem, with slightly different language in the dialog box prompting me to save the php file.)

    Here is my /etc/apache2/vhosts/Vhosts_ispconfig.conf contents:

    ###################################
    #
    # ISPConfig vHost Configuration File
    # Version 1.0
    #
    ###################################
    #
    NameVirtualHost 192.168.2.102:80
    <VirtualHost 192.168.2.102:80>
    ServerName localhost
    ServerAdmin root@localhost
    DocumentRoot /var/www/sharedip
    </VirtualHost>
    #
    #
    ######################################
    # Vhost: www.myservername.net:80
    ######################################
    #
    #
    <VirtualHost 192.168.2.102:80>
    ServerName www.myservername.net:80
    ServerAdmin webmaster@myservername.net
    DocumentRoot /srv/www/web1/web
    ServerAlias salmoneggs.net
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    ErrorLog /srv/www/web1/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    php_admin_flag safe_mode Off
    Alias /error/ "/srv/www/web1/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /srv/www/web1/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /srv/www/web1/user/$1/web/$3
    </VirtualHost>
    #
    #
    #

    After making changes I have changed the "Space MB" value on the website through the ISPConifg control panel and checked the Vhosts_ispconfig.conf to make sure it has been reflected.

    I still receive a prompt to download php files instead of them being displayed in the browser. Thanks in advance for your help. But for this problem, I am a huge fan of your guides and support.
     
  6. bionictrout

    bionictrout New Member

    FYI, once again I tried the 'addhandler' as you instructed above, and it has the same result (of course, after making the change I changed the quota value in the website to rewrite the vhosts file.)

    [​IMG]
     
  7. bionictrout

    bionictrout New Member

    Wait second... If I add /index.php to the end of the URL, it seems to load, with the 'addhandler' directive. So, maybe there is only a directory index issue now?

    The indexes appear to be in place properly--any ideas what is wrong?
     
    Last edited: Aug 20, 2007
  8. bionictrout

    bionictrout New Member

  9. Keeze

    Keeze New Member

    Is there a solution for this problem when you use 42go?

    I cannot find the lines repeated many times in this tread in config.inc.php (in jake:/home/adm42go/42go#)

    Kind regards,
    Kees
     
  10. Ben

    Ben HowtoForge Supporter

    Will the above mention fix have to be implemented after every update of ISPConfig?
     
  11. till

    till Super Moderator

    The things explained above are a configuration setting and not a fix as no program code is changed. All configuration settings stay during updates.
     
  12. datahellas

    datahellas New Member

    worked on open suse 10.3!

    The addhandler worked for me on Open Suse 10.3. I had to modify one of my sites in ISPConfig, as described, for this to work. Errors stopped! Thank you!
     
  13. RayZ

    RayZ New Member

    check you apache2.conf

    There are duplicate includes of vhosts_ispconfig.conf.
    It seems, that you're reinstalled your ISPconfig. It's adding new itself configuration, duplicating it's previous one.
     
  14. ivantea

    ivantea New Member

    Describe the configuration

     
  15. falko

    falko Super Moderator

    Go to a web site in ISPConfig (doesn't matter which one) and change a setting for this web site (e.g. disable SSI). Wait a few minutes and switch on SSI again. That will cause ISPConfig to rewrite Vhosts_ispconfig.conf.
     
  16. sajo

    sajo New Member

    THANKS !!!
    addtype solved my problem :)
     

Share This Page