Filepaths messed up

Discussion in 'General' started by JamesShijie, Jul 7, 2010.

  1. JamesShijie

    JamesShijie New Member

    Hi there,

    I have 2 clients added in my ispconfig 3 -- client1 and client2. Client1 has a website added to it, Client2 also has a website added, However, no matter WHAT I do, EVERYTHING redirects to client1's /web directory. Even my server address, redirects there. I looked here:


    And it has several files, including and --However, looking into, say,, the filepaths were all correct to go to where they need to go! So what should I do? In my regular httpd.conf file, it has this: Include /etc/httpd/conf/sites-enable - which means that it SHOULD work. Why doesn't it!?

    Thanks in advance, everyone has been very helpful here.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Does not look like a problem with file paths. Its more a dns or web settings problem.

    Ensure that:

    1) Both domains have a dns A-Record for the domain itself and the subdomain www that point to the IP address of the server.
    2) That you selected this IP address in the website settings of both websites.
    3) that you entered the domain names as and not in the domain field.
    4) That you enabled auto subdomain www.
  3. JamesShijie

    JamesShijie New Member

    Whenever I try to select an IP address, all it has is a '*' instead. Is this ok, or where do I go about changing this to my server IP address?
  4. JamesShijie

    JamesShijie New Member

    I've played around with it a bunch, and have deleted all my clients. Now, in the admin tool, with 0 clients, I add 2 websites, with client0 --the default client, as the owner:

    But no matter what I do, everything directs to the first site I created, --why is that? If you need me to post any vhost entries or anything, let me know.
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Please do what i suggested above and select the ip address and not *. if the ip is not listed there, add it under system > server ip.
  6. JamesShijie

    JamesShijie New Member


    I needed to add the server IP address. Thank you so much. You guys are really helpful here, and It's much appreciated.
  7. JamesShijie

    JamesShijie New Member

    Now it's redirecting all my sites to /var/www/html, and not using their apache directives. Do I need to redo them all, or is there anything I can change? I made sure I had www on the options, and the ip address of the server was selected. The a-records are correct on the DNS side of things.
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    you have either to use * for all sites or the ip addressbut do not mix it.
  9. JamesShijie

    JamesShijie New Member

    I have them all using the IP Address, as you suggested. No site is using the "*". And now, all the traffic is going to /var/www/html -- Is there anything else I can check?

Share This Page