File isn't in mbox format

Discussion in 'Installation/Configuration' started by adamluz, Jun 21, 2006.

  1. adamluz

    adamluz New Member

    Signed in to webmail and got the following error:

    ERROR: Could not complete request.
    Query: SELECT "INBOX"
    Reason Given: Internal error occured. Refer to server log for more information. [2006-06-21 14:25:45]

    So I used webmin to see if the user's mail was readable and I was able to read everything in the user's e-mail with no problem. When I checked the mail log though its reporting: Jun 21 14:25:45 fc4 imap(web39_mick): File isn't in mbox format: /var/mail/web39_mick

    All accounts were created using ISPconfig. I have never made any changes to ispconfig with the maildir or mbox. So my question is, how do I restore this so its readable by clients and the server thinks its mbox. Its still in one file, looks like an mbox file to me, so I am stuck....
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I guess the mbox file gots corrupted. I'am not sure if there is a solution to fix that, but maybe there are tools that are able to check for errors in the mbix format.

    The quick and dirty solution is to rename the mbox file and let postfix create a new file when the next email arrives, but you will loose the emails stored in the mbox.

    Generally ist better to youe Maildir with a Maildir capable pop3 daemon because mbox is known to get corruption problems from time to time.
  3. adamluz

    adamluz New Member

    My soltuion: (not the best but it works with out loosing e-mails)

    I used webmin tools under the "Read User Mail" to solve the issue

    1. Create a second user account similar to the one broken, in my case I had ispconfig create web39_mick2

    2. Sign in to webmin and go to the Read User Mail tool. Go to the account having trouble and use the copy function to copy the e-mails to the new account. If you have multiple folders, you have to go folder by folder.

    3. Delete the troubled account (remember, if you are using ISPconfig to delete the account, you need to remove that account from the recycle bin as well)

    4. Re-create the troubled account

    5. Reverse copy the files back to that first account and everything should work fine again.

    6. Restart postfix, pop3 & imap, and ispconfig (don't know which one to restart so I restarted all of them to get e-mails to start working again.)

    SIDE NOTE: E-Mails were bouncing when the account was down.
  4. sharif4u

    sharif4u New Member

    If you see below error message
    File isn't in mbox format: /var/mail/web39_mick

    Then open the file with any text editor like vi /var/mail/web39_mick
    then Delete the garbage lines(one or two) at the beginning and save the file.

    Restart the service and everything shloud be OK now.
  5. djeshelman

    djeshelman New Member

    Had the same issue

    I'm lucky I had only one user with this issue- a server with about 100 users was powered down 'uncomfortably' two days ago, so fortunately this is the only one I've seen so far. But, if it helps anyone else, here's what I did-

    I have Webmin with Usermin installed, so there's an easier way to handle this:

    Oddly enough, when I had this problem I could see my user's mail in Usermin or Webmin/Read User Mail, but not via POP/IMAP or Squirrelmail

    So, logged in as the user in Usermin, I made a new folder, and copied all the mail to the new folder.

    I then removed the 'inbox' directly out of the /var/mail directory, created a new file and did a chown to match the old one.

    I restarted postfix and dovecot but I don't know if that will be necessary or not.

    The process took mere moments once I figured out what to do.

    good luck!

Share This Page