File and directory permissions

Discussion in 'General' started by miguelpinheiro, Nov 18, 2008.

  1. miguelpinheiro

    miguelpinheiro New Member

    Hi there!
    I'm almost getting crazy with setting the owner, file permisions of my site.
    After getting ISPConfig 2 working using the superb How-to guide in Ubuntu 8.04, I installed Joomla 1.5.

    During the install I had to change configuration.php to 777 in order to be able to write on that file all my joomla settings.

    Then I went to install a module and it throws the message:

    1)I've changed all file and directory permissions to 777 inside the "web1" directory just to see if it works but I get the same message.

    2)Tried using joomla ftp layer without any luck.

    3) I've tried to change the owner off all files and directories to "www-data:www-data" to see if it solves but, again the same message.

    4) I've tried suPHP following the guide to Ubuntu 7.04 - I'm not sure if I can use it as I'm executing php as an apache module.
    After disabling the php5 module from apache the apache server wouldn't start. Then I proced with the suPHP compilation and it failed again although it generated the .so file (????). So I modified the httpd.conf file (wich was empty) and put the line stated on the how-to.
    After that, the apache server wouldn't start. So I enabled again php5 module and finally I get it up.
    I do not know if this is the right way of installing suPHP.

    And I do not know what to do next... :confused:

    Can someone help me give me ideas on what to test? Some hits

    Many thanks. Regards.
    Last edited: Nov 18, 2008
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Joomla 1.5 has a FTP layer, you can configure it trough the joomla setup to circumvent permission problems.
  3. miguelpinheiro

    miguelpinheiro New Member

    I did it and still couldn't install any component. It gave me the same error.

    I noticed that some directories and files stills are owned by www-data user instead of web1... user. I'll check this and make sure all files and directories are owned by web1...

    I'll update this thread with the results.
    Last edited: Nov 19, 2008
  4. miguelpinheiro

    miguelpinheiro New Member

    I finally get it working. Here are the steps I followed:
    1) disabled joomla ftp layer
    2) All the directories listed in Help->Info->Permissions I changed it to 0777.


Share This Page