fgets() error:

Discussion in 'Installation/Configuration' started by internetcb, Jul 15, 2010.

  1. internetcb

    internetcb New Member

    Currently php5-cgi is the only version of PHP I have installed, and I get this error over and over again when I try to install ISPConfig 3, any suggestions?


    Select language (en,de) [en]: <br />
    <b>Notice</b>: Use of undefined constant STDIN - assumed 'STDIN' in <b>/home/chris/www/ispconfig3_install/install/lib/install.lib.php</b> on line <b>190</b><br />
    <br />
    <b>Warning</b>: fgets(): supplied argument is not a valid stream resource in <b>/home/chris/www/ispconfig3_install/install/lib/install.lib.php</b> on line <b>190</b><br />
  2. Mark_NL

    Mark_NL New Member

    you need php5-cli to install ispconfig .. besides that ispconfig3 also needs php5-cli to run it's cronjobs ..
  3. internetcb

    internetcb New Member

    OK I installed php5-cli and I still get the same thing :-( Any other suggestions as to what I might be missing?
  4. Mark_NL

    Mark_NL New Member

    hmm strange, must be missing something .. you're running debian? ubuntu?

    the how-to at some point tells you:

    11 Install Apache2, PHP5, phpMyAdmin, FCGI, suExec, Pear, And mcrypt

    Apache2, PHP5, phpMyAdmin, FCGI, suExec, Pear, and mcrypt can be installed as follows:
    apt-get install apache2 apache2.2-common apache2-doc apache2-mpm-prefork apache2-utils libexpat1 ssl-cert libapache2-mod-php5 php5 php5-common php5-gd php5-mysql php5-imap phpmyadmin php5-cli php5-cgi libapache2-mod-fcgid apache2-suexec php-pear php-auth php5-mcrypt mcrypt php5-imagick imagemagick libapache2-mod-suphp

Share This Page