FFmpeg install problem multiple methods

Discussion in 'Installation/Configuration' started by Chad, Jul 17, 2008.

  1. Chad

    Chad New Member

    Trying to install FFmpeg through this method:

    http://forums.theplanet.com/index.php?showtopic=64541

    I went through halfway without errors until the below command:

    [email protected] [/usr/local/src]# svn checkout svn://svn.mplayerhq.hu/ffmpeg/trunk ffmpeg
    -bash: svn: command not found


    I also tried:

    perl -MCPAN -e shell
    cpan> install FFmpeg

    Errors

    Code:
    FFmpeg.xs:659: error: invalid type argument of `->'
    FFmpeg.c: At top level:
    ./ffmpeg-6036.c:95: error: storage size of `frame_pix_fmt' isn't known
    ./ffmpeg-6036.c:258: error: storage size of `bitstream_filters' isn't known
    {standard input}: Assembler messages:
    {standard input}:473: Error: symbol `video_disable' is already defined
    {standard input}:479: Error: symbol `video_stream_copy' is already defined
    {standard input}:485: Error: symbol `audio_language' is already defined
    {standard input}:491: Error: symbol `audio_disable' is already defined
    {standard input}:497: Error: symbol `audio_stream_copy' is already defined
    {standard input}:1027: Error: symbol `resampling_dst' is already defined
    {standard input}:1033: Error: symbol `final_picture' is already defined
    {standard input}:1064: Error: symbol `p' is already defined as "*COM*"/4
    {standard input}:1070: Error: symbol `video_codec_id' is already defined
    {standard input}:1076: Error: symbol `audio_codec_id' is already defined
    make: *** [FFmpeg.o] Error 1
      ALLENDAY/FFmpeg-6036.tar.gz
      /usr/bin/make -- NOT OK
    Running make test
      Can't test without successful make
    Running make install
      Make had returned bad status, install seems impossible
    Failed during this command:
     ALLENDAY/FFmpeg-6036.tar.gz                  : make NO
    I have Cpanel on Centos 5
     
  2. topdog

    topdog Active Member HowtoForge Supporter

    for method1 you need to run this first
    Code:
    yum install subversion
     

Share This Page