Few issues with email

Discussion in 'Installation/Configuration' started by IKShadow, Nov 23, 2006.

  1. IKShadow

    IKShadow New Member

    Specs ( read siganture :) )

    1. I dont receive any emails, but I can send them.

    2. Roundcube (pkg installation) when i send email the From is: [email protected]

    Code:
    krneki:/var/log/apache2 # netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 localhost:737           *:*                     LISTEN      3529/famd
    tcp        0      0 *:mysql                 *:*                     LISTEN      2348/mysqld
    tcp        0      0 *:sunrpc                *:*                     LISTEN      2590/portmap
    tcp        0      0 localhost:novell-zen    *:*                     LISTEN      2668/zmd
    tcp        0      0 *:hosts2-ns             *:*                     LISTEN      3257/ispconfig_http
    tcp        0      0 *:ftp                   *:*                     LISTEN      4925/proftpd: (acce
    tcp        0      0 krneki.ikshadow.:domain *:*                     LISTEN      3804/named
    tcp        0      0 localhost:domain        *:*                     LISTEN      3804/named
    tcp        0      0 *:smtp                  *:*                     LISTEN      5002/master
    tcp        0      0 localhost:953           *:*                     LISTEN      3804/named
    tcp        0      0 *:imaps                 *:*                     LISTEN      2729/couriertcpd
    tcp        0      0 *:pop3s                 *:*                     LISTEN      2717/couriertcpd
    tcp        0      0 *:pop3                  *:*                     LISTEN      2722/couriertcpd
    tcp        0      0 *:imap                  *:*                     LISTEN      2728/couriertcpd
    tcp        0      0 *:www-http              *:*                     LISTEN      3502/httpd2-prefork
    tcp        0      0 *:ssh                   *:*                     LISTEN      2810/sshd
    tcp        0      0 *:smtp                  *:*                     LISTEN      5002/master
    tcp        0      0 localhost:953           *:*                     LISTEN      3804/named
    tcp        0      0 *:https                 *:*                     LISTEN      3502/httpd2-prefork
    tcp        0      0 krneki.ikshado:www-http crawl-66-249-66-1:43296 ESTABLISHED 9673/httpd2-prefork
    tcp        0      0 krneki.ikshado:www-http crawl-66-249-66-1:62256 ESTABLISHED 10200/httpd2-prefor
    tcp        0      0 krneki.ikshado:www-http 190-39-206-6.dyn.d:4105 TIME_WAIT   -
    tcp        0  27588 krneki.ikshado:www-http dsl-189-158-179-3.:wlbs ESTABLISHED 9707/httpd2-prefork
    tcp        0      0 krneki.ikshado:www-http dsl-189-158-1:ppcontrol ESTABLISHED 10510/httpd2-prefor
    tcp        0      0 krneki.ikshado:www-http dsl-189-158-179:jbroker FIN_WAIT2   -
    tcp        0      0 krneki.ikshado:www-http 190-39-206-6.dyn.d:4117 TIME_WAIT   -
    tcp        0      0 krneki.ikshado:www-http 190-39-206-6.dyn.d:4116 TIME_WAIT   -
    tcp        0  13068 krneki.ikshado:www-http dsl-189-158-1:citrixima ESTABLISHED 10512/httpd2-prefor
    tcp        0      0 krneki.ikshado:www-http 190-39-206-6.dyn.d:4113 TIME_WAIT   -
    tcp        0  14520 krneki.ikshado:www-http dsl-189-158:citrixadmin ESTABLISHED 10517/httpd2-prefor
    tcp        0      0 krneki.ikshado:www-http 190-39-206-6.dyn.d:4115 TIME_WAIT   -
    tcp        0      0 krneki.ikshado:www-http 190-39-20:jomamqmonitor TIME_WAIT   -
    tcp        0      0 krneki.ikshado:www-http 62-7-246:hp-device-disc FIN_WAIT2   -
    tcp        0    740 krneki.ikshadow.com:ssh tm.213.143.90.139.:2217 ESTABLISHED 3909/sshd: admin [p
    tcp        0      0 krneki.ikshado:www-http 62-7-246-201.adsl:bbars FIN_WAIT2   -
    Code:
    krneki:/var/log # vi mail.err
    Nov 15 21:36:37 linux postfix/postfix-script: fatal: the Postfix mail system is not running
    Nov 15 21:39:49 linux postfix/postfix-script: fatal: the Postfix mail system is not running
    Nov 15 21:39:55 linux postfix/postfix-script: fatal: the Postfix mail system is not running
    Nov 15 21:58:08 krneki postfix/postfix-script: fatal: the Postfix mail system is not running
    Nov 18 17:44:30 krneki postfix/master[3658]: fatal: open lock file pid/master.pid: unable to set exclusive lock: Resource temporarily unavailable
    Nov 20 19:53:46 krneki postfix/postfix-script: fatal: usage: postfix start (or stop, reload, abort, flush, check, set-permissions, upgrade-configuration)
    Nov 22 09:00:53 krneki postfix/master[3637]: fatal: open lock file pid/master.pid: unable to set exclusive lock: Resource temporarily unavailable
    Nov 22 23:57:22 krneki postfix/master[3646]: fatal: open lock file pid/master.pid: unable to set exclusive lock: Resource temporarily unavailable
    Only few parts of log.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Postfix seems to be running. Please post an excerpt of your mail.log file so we can check where the mail gets delivered to.
     
  3. falko

    falko Super Moderator ISPConfig Developer

    Please run
    Code:
    postmap /etc/postfix/virtusertable
    and replace check_relay_domains with reject_unauth_destination in /etc/postfix/main.cf. Then restart Postfix.
     
  4. IKShadow

    IKShadow New Member

    I did it.. I got errors stoping/starting postifx:
    Code:
    krneki:/_archive/install_ispconfig # /etc/rc.d/postfix stop
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    Shutting down mail service (Postfix)                                  done
    krneki:/_archive/install_ispconfig # /etc/rc.d/postfix start
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    Starting mail service (Postfix)                                       done
    krneki:/_archive/install_ispconfig #
    Still cant receive any email's.

    here are my mail logs
    http://www.ikshadow.com/stuff/mail_logs.rar
     
    Last edited: Nov 23, 2006
  5. falko

    falko Super Moderator ISPConfig Developer

    This happens because you run the command from a non-existant directory (/_archive/install_ispconfig). Nothing to worry about. :)

    Can you post the relevant parts here directly?
     
  6. IKShadow

    IKShadow New Member

    hmm i think the problem is couse mx record are not found for my domain's.

    I will fix this first then we will see.


    p.s. I still think the problem 2 will remain ... roundcube.
     
  7. IKShadow

    IKShadow New Member

    I dont have any MX records in /etc/named.conf ... it seems they are not made by ISPConfig .( I did checked Create DNS-MX)
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    MX records are not written to the named.conf, they are declared inside the pri... files which where included in the named.conf
     
  9. IKShadow

    IKShadow New Member

    inside pri ?

    where can i checked them ?
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    That depends on your linux distribution. Have a look at /etc/named or /var/lib/named or a similar directory under /var.
     

Share This Page