fetchmailrc question

Discussion in 'Server Operation' started by gw1500se, Mar 15, 2011.

  1. gw1500se

    gw1500se New Member

    I am getting inundated with messages from fetchmail. Since I am not using syslog, I guess it is sending it via email. I can only find information on how to turn off syslog. How do I turn off (or modify to get only errors) all these warning emails? TIA.
     
  2. falko

    falko Super Moderator

    What do these warnings look like?
     
  3. gw1500se

    gw1500se New Member

    One for each mailbox each time fetchmail runs:

    fetchmail: Warning: "Maillennium POP3/PROXY server" found, using RETR command instead of TOP.
    fetchmail: No mail for mailbox at mail.mydomain.net
     
  4. falko

    falko Super Moderator

    Take a look at
    Code:
    man fetchmail
    You can suppress warnings with the -s or --silent switch.
     
  5. gw1500se

    gw1500se New Member

    Thanks but that didn't change anything. I still get the same warnings every 5 minutes.
     
  6. falko

    falko Super Moderator

    Where did you add the switch? In the fetchmailrc file (don't know if that works), or in the fetchmail startup command in the fetchmail init script (probably /etc/init.d/fetchmail)?
     
  7. gw1500se

    gw1500se New Member

    I run fetchmail from cron.

    */5 * * * * /usr/bin/fetchmail --silent
     
  8. falko

    falko Super Moderator

    Can you post the fetchmailrc file (please x out the passwords!)?
     
  9. gw1500se

    gw1500se New Member

    Thanks for your time. Here it is:
    Code:
    set postmaster "mailman"
    set bouncemail
    set no spambounce
    set properties ""
    poll mailhost.somedomain.com
            proto pop3
            user "cufsalumni"
            pass "xxxxxxxxx"
            is cufsalumni
            user "cufsalumni-request"
            pass "xxxxxxxxx"
            is cufsalumni-request
            user "cufsalumni-join"
            pass "xxxxxxxxx"
            is cufsalumni-join
            user "cufsalumni-leave"
            pass "xxxxxxxxx"
            is cufsalumni-leave
            user "cufsalumni-confirm"
            pass "xxxxxxxxx"
            is cufsalumni-confirm
            user "cufsalumni-owner"
            pass "xxxxxxxxx"
            is cufsalumni-owner
            user "mailman-owner"
            pass "xxxxxxxxx"
            is mailman-owner
    
    
     
  10. falko

    falko Super Moderator

    Not sure if this works, but maybe you can add "silent" to each mailbox, e.g.:

    Code:
    poll mailhost.somedomain.com
            proto pop3
            user "cufsalumni"
            pass "xxxxxxxxx"
            is cufsalumni [COLOR="Red"]silent[/COLOR]
     
  11. gw1500se

    gw1500se New Member

    Thanks but that didn't help. However, I am getting a new message now but I don't think it is related. At the same time I don't know what it means.

    fetchmail: warning: multidrop for mail.myisp.com requires envelope option!
    fetchmail: warning: Do not ask for support if all mail goes to postmaster!
     

Share This Page