fetchmail Virtual Users And Domains With Postfix, Courier And MySQL (Ubuntu 7.10)

Discussion in 'HOWTO-Related Questions' started by c0mputernick, Jan 12, 2008.

  1. c0mputernick

    c0mputernick New Member

    Ive followed this setup perfectly and have a nice working mail server.
    My question is that how can you add fetchmail to fetch users email gmail, yahoo etc and have them go to the correct box? if the users are virtual how would i tell fetchmail where to put the fetched mail? can fetchmail hand it off to one of the other programs (amavis for example) and have it delivered that way after its spam and virus checks? or possibly drop it off with postfix, then postfix will send if off to be scanned and then deliver the mail since it knows who and where the users are?
    im just confused about how to accomplish that.:confused:

    Thanks for any and all help.

    Nick
     
  2. Leszek

    Leszek New Member

  3. c0mputernick

    c0mputernick New Member

    I have added that file, changed the settings for my account i want to fetch, but it still doesnt do anything. it doesnt seem to work in a virtual env.
    doesnt fetchmail look for config files in: $HOME/.fetchmailrc?
    when i try run fetchmail (as root or user) i get :
    fetchmail: no mailservers have been specified.

    but they are clearly defined in the fetchmailrc file i put in the /etc dir.

    any other ideas?

    Thanks for the help.

    EDIT:
    Nevermind, i left the <>'s in there by mistake. seems to be fetching now...

    Thanks for the help.
     
    Last edited: Jan 15, 2008
  4. niklas78

    niklas78 New Member

    What did you put as <username>?

    What did you put as <username>?

    I am about to test this setup, but did you set a UnixUser as username or a virtual e-mail "user" as username?

    BR,

    Niklas
     
  5. c0mputernick

    c0mputernick New Member

    I put the email address of the user you want the mail to be delivered to:
    username@domain.com

    In my case i was checking gmail accounts, so the "REMOTE_USER" portion has to be the full email address as well. but it depends on how you login to your remote server.

     

Share This Page