FetchMail - Getmail ISPconfig3

Discussion in 'Installation/Configuration' started by sheshes, Dec 11, 2009.

  1. sheshes

    sheshes Member

    Hi Tim, Falko

    I have read previous posts about errors of getmail in /var/log/ispconfig/cron.log but it doesn't seem to work.

    I want to fetchmail from a pop3 server for one of my users. Since there isn't any port functionality in the interface or SSL option I have tried ssl:// infront of the server and it still doesn't create a conf file here are the errors.

    I have created a new Fetchmail Account but still the error
    hmod: cannot access `/etc/getmail/ssl:[email protected]': No such file or directory
    chown: cannot access `/etc/getmail/ssl:[email protected]': No such file or dir

    The same thing works super in squirrelmail using the mail_fetch plugin but as you can understand I don't want the user to have to login to webmail first retrieve mails from external pop.

    Please give me some help on that

    Thanks
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The errors occur because you added ssl:// in front of the server. In the server filed you can only add the servername, in your case something like hotmail.com or mail.hotmail.com or whatever they use. SSL is not supported in ispconfig yet.
     
  3. sheshes

    sheshes Member

    That's exactly what I was aiming to do. My user wants all his hotmail mails to be fetched. I guess I'll have to wait for the next update.

    Thanks a lot
     
  4. alkosmurf

    alkosmurf New Member

    I wanna fetch all my email's from my Gmail account :(

    But I cant get it to work :(
     
  5. cypriot

    cypriot New Member

    Multi destination for fetchmail on ispconfig3

    Hi There,
    Is there anyway adding multi destination in fetchmail settings ? i want to be able to get the emails into 2 mail account from 1 account..
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    There is no multi delivery in getail, but you can get this result by using a email alias. Let getmail deliver the emails to this alias and set the two mailboxes as recipients in the alias settings.
     
  7. cypriot

    cypriot New Member

    Thank you so much for your reply.

    we have 40 mail account from our hosting provider and we use 3 group of mail account from all,
    admin@ (this account have all the mails in here)
    users@ (this account have limited amount mail accounts access)
    sales@ (this account have limited amount mail accounts access)

    so on the control panel in ispconfig3
    do you mean to say ?
    we create 1 local mail account call it mails@..... and fetch it all in here like the admin@....

    but the problem is how will we able to say to the script copy all the mails from some accounts only into users@ and sales@ also ?
     
  8. cypriot

    cypriot New Member

    error showing when i try to add why is that pls ?
    ERROR

    There is already a mailbox with this email address.

    am i not suppose to use excising email address ??
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    No, you have to use a email address that does not exist.
     
  10. cypriot

    cypriot New Member

    hmmm confusing , as if the local email address isnt exist how will i be able to login to it using roundcube on the same server :(
     
  11. JeffryL

    JeffryL New Member

    Was dealing with the same problem. The solution is quite easy. Just setup fetch mail (get mail) in the ISPConfig panel as you would do with any other account. Then from commandline edit the file with you account data (as root) with:

    Code:
    nano /etc/getmail/pop_gmail_com_account.com.conf
    and change this:

    Code:
    [retriever]
    type = SimplePOP3Retriever
    to:

    Code:
    [retriever]
    type = SimplePOP3SSLRetriever
    Don't run run-getmail.sh then (as root). This will result in errors. Just let the cron do his job.

    NEVER MIND... I'm the one being dumb here. This is also possible from the panel itself... But you do need to use SSL anyway...
     
    Last edited: May 18, 2014

Share This Page