Fehlermeldung

Discussion in 'General' started by wotan2005, Oct 9, 2008.

  1. wotan2005

    wotan2005 New Member

    Hallo,

    leider ist mein Englisch nicht so gut, das ich hier den fehler in englisch schreiben kann.

    folgende Fehlermeldung bekomme ich:
    Fatal error: Call to undefined function mysql_connect() in /usr/share/mydnsconfig/lib/classes/db_mysql.inc.php on line 75

    Ich habe mich direkt an die Installationsanleitung aus dem Tar gehalten.

    Folgendes OS:
    Debian Etch

    Software:
    Apache2
    MySQL-Server
    MySQL-Client
    PHP5
    PHP5-MySQL
    PHPMyAdmin
    MyDNS-MySQL

    Bitte um Hilfe!

    PHPMyAdmin läuft einwandfrei und hat auch Zugriff auf den MySQL-Server.
     
  2. till

    till Super Moderator

    Please execute the following command as root:

    apt-get install php5-mysql

    and then try again.
     
  3. wotan2005

    wotan2005 New Member

    Hallo,

    ist installiert, da sonst der PHPMyAdmin nicht laufen würde.
    Code:
    dpkg -l | grep php
    ii  libapache2-mod-php5    5.2.0-8+etch13                       server-side, HTM                                             L-embedded scripting languag
    ii  php5                   5.2.0-8+etch13                       server-side, HTM                                             L-embedded scripting languag
    ii  php5-common            5.2.0-8+etch13                       Common files for                                              packages built from the php
    ii  php5-mysql             5.2.0-8+etch13                       MySQL module for                                              php5
    ii  phpmyadmin             2.9.1.1-8                            Administrate MyS                                             QL over the WWW
    
     
  4. till

    till Super Moderator

    No, not nescessarily as phpmyadmin runs with mysqli too, but mydnsconfig requires mysql and does not work with mysqli.

    Please create a file containing the phpinfo(); command and put it in the same folder then mydnsconfig, open the file in a browser and check that the mysql php extension (and not only the mysqli extension) is loaded.
     
  5. wotan2005

    wotan2005 New Member

    Code:
    /etc/php5/apache2/conf.d/mysql.ini, /etc/php5/apache2/conf.d/mysqli.ini, /etc/php5/apache2/conf.d/pdo.ini, /etc/php5/apache2/conf.d/pdo_mysql.ini
    
    und
    Code:
    mysql
    MySQL Support	enabled
    Active Persistent Links 	0
    Active Links 	0
    Client API version 	5.0.32
    MYSQL_MODULE_TYPE 	external
    MYSQL_SOCKET 	/var/run/mysqld/mysqld.sock
    MYSQL_INCLUDE 	-I/usr/include/mysql
    MYSQL_LIBS 	-L/usr/lib -lmysqlclient
    
    Directive	Local Value	Master Value
    mysql.allow_persistent	On	On
    mysql.connect_timeout	60	60
    mysql.default_host	no value	no value
    mysql.default_password	no value	no value
    mysql.default_port	no value	no value
    mysql.default_socket	no value	no value
    mysql.default_user	no value	no value
    mysql.max_links	Unlimited	Unlimited
    mysql.max_persistent	Unlimited	Unlimited
    mysql.trace_mode	Off	Off
    
    Und neuer Versuch
     
  6. wotan2005

    wotan2005 New Member

    Danke läuft jetzt.

    Sollte man vielleicht aber noch mit in Install reinschreiben.
     

Share This Page