Fehler 404 - Datei nicht gefunden

Discussion in 'Installation/Configuration' started by LeoLinux, Jul 4, 2006.

  1. LeoLinux

    LeoLinux New Member

    Hi,

    I installed ISPconf after falkos HowTo successfully on a Ubuntu Breezy Badger.
    The Server is behind a m0n0wall with a dyndns account and all necessary ports are forwarded.

    Server info:
    Code:
    [email protected]:~# ifconfig
    eth0      Link encap:Ethernet  HWaddr 00:16:3E:1A:BE:50
              inet addr:192.168.1.101  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::216:3eff:fe1a:be50/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:1144 errors:0 dropped:0 overruns:0 frame:0
              TX packets:1234 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:204186 (199.4 KiB)  TX bytes:1160831 (1.1 MiB)
    
    lo        [...
                                 ...]
    
    [email protected]:~# hostname -f
    server1.pc1mail.de
    [email protected]:~# hostname
    server1.pc1mail.de
    [email protected]:~#
    
    ^^http://pc1mail.de is forwarded to http://pc1service.gotdns.com

    I logged in as admin an createt a customer account (filled in the basics and settet up an username and password)
    after I saved this I created an web for the customer like you can see on the following screenshot:

    http://hure.gotdns.com/ISPconf/Bildschirmphoto1.png

    ^^ admittedly I don't know what the www is standing for or what it means because my hostname isn't www?!
    The secound thing is that my server's name is shown as "Server 1" on the screenshot above - is this correctly - I mean the space between server an the one?

    After that I created a co-domain - but without much success because I don't know how to handle. I sadly couldn't understand the examples in the admin howto. but I tried ma luck anyway. You could see a screenshot of it below:
    http://hure.gotdns.com/ISPconf/Bildschirmphoto4.png

    http://hure.gotdns.com/ISPconf/Bildschirmphoto5.png
    ^^ could you tell me what "create dns and create mx is standing for? And in what way are they neccessary for creating a subdomain?

    With the shown screenshot entries on the ISPconf I get allways ERROR 404 when I type http://pc1mail/web1
    once it is in blue - powerd by ISPconf - and when I'm playing with the "create dns and dns mx" options it will be shown the same error 404 but not with the blue design.

    if I left dns stuff empty and log in as the customer I can rech my ftp space via webftp but not from outside? How is the domain for it from ouside and why do I always get error 404?

    On my server is nothing more or less installed than falko's howto is telling.

    #######################################

    my goal is it to create a subdomain for each web like web1.pc1mail.de and how to reach web space ftp from outside (but I think that's solved with the subdomains - am I right?)


    Thanks for helping and describing! ;-)

    best regards!
    Leander
     
    Last edited: Jul 5, 2006
  2. falko

    falko Super Moderator ISPConfig Developer

    Please post in English. We don't answer posts in other languages.
     
  3. LeoLinux

    LeoLinux New Member

    Hi,

    Sorry - I have translate it.

    Thanks,
    Leo
     
  4. planet_fox

    planet_fox Member

    Host is www
    and Hostname is pc1mail.de

    Co musst set by hostname none

    is for name server when you try on browser or other

    www.pc1mail.de or http://pc1mail.de is the same

    When you try on the basic ISP Web by

    host none and save you, and ty www.pc1mail.de you come to
    rootDoc from your server
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Is 195.20.225.111 your public IP address?
    What's in Vhosts_ispconfig.conf?

    That's the server name you enter under Management -> Server -> Settings -> Server -> Server Name. It has nothing to do with the hostname of the server, it's just a string so that you know which server it is. :)

    Did you forward port 21 from your router to your ISPConfig server? Have you tried both active and passive transfers in your FTP client?
    You can use any FQDN that points to your router's public IP address. You can also use the router's public IP address.

    The "Default DNS" and Default MX" checkboxes let you create standard DNS records for your domain, but it makes sense only if your ISPConfig server is the authoritative name server for your domain. Most likely this is not the case, so you don't need to check them.
     

Share This Page