Fedora9 & ISPConfig Install showstopper

Discussion in 'Installation/Configuration' started by ghall, Jul 14, 2008.

  1. ghall

    ghall Member

    Hello,

    I used the guidelines to install ISPConfig v2.2.24 to Fedora9 here:

    The Perfect Server - Fedora 9

    Everything seemed to be working fine except that when I reboot it gets to:

    Starting ISPConfig System... [OK]
    /root/ispconfig/httpd/bin/apachect1 startssl: httpd started

    After that the computer pops out of detailed startup mode and hangs before the login gui.

    I've retried to install this from scratch twice already and have resulted in the same problem.

    Any advice on how to recover the system?
     
  2. sergio.morales

    sergio.morales New Member

    well you're not busted . . .

    Get a system shell if you can get one . . . go to /etc/shells and remove the entry in capital letters which is something like /ETC/SOMETHING/BOGUS (I gorgot the actual verbiage, but it's impossible to miss!!).

    Reboot and you should be fine. THis bit me too!! AAGGHH!!

    sERGE
     
  3. sergio.morales

    sergio.morales New Member

  4. ghall

    ghall Member

    This is the only entry in the shells file:

    /bin/sh
    /bin/bash
    /sbin/nologin
    /bin/zsh
    /bin/false
    /SENDMAIL/ANY/SHELL/

    Do I remove it all or just the /SENDMAIL/ANY/SHELL/ ???

    Thanks for your help
     
  5. ghall

    ghall Member

    Ok that seems to have fixed that problem and am now wondering what's boken after removing /SENDMAIL/ANY/SHELL/ ??

    I am now able to login ok.

    Thanks!
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Nothing if you use Postfix. :)
     
  7. ghall

    ghall Member

    That's good. I noticed it installs somewhere during the ISPConfig install. Any chance you could add a line item in the Perfect Fedora 9 Install to remove this little annoyance before you reboot?

    It has become an additional step for me.
     
  8. rvakili

    rvakili New Member HowtoForge Supporter

    Same blank blue screen

    Hi Guys I removed /SENDMAIL/ANY/SHELL/ and still experiencing same problem.

    Any other thing I should change?
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Reboot the server afterwards.
     
  10. rvakili

    rvakili New Member HowtoForge Supporter

    Done so 3 times. I also change the Fedora template as it was in another posting from infinity to circullar with no luck

    Thanks
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the content of the file:

    /etc/shells
     
  12. rvakili

    rvakili New Member HowtoForge Supporter

    /bin/sh
    /bin/bash
    /sbin/nologin
    /bin/tcsh
    /bin/csh
    /bin/false

    Thnks Till
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats ok so far. I guess that your problem is not related to the ispconfig user then. There must be something else broken in your setup. Take a look in your log files and search for errors
     
  14. Mr. Print

    Mr. Print New Member

    Problem solved: Many seemed to have the problem I had after Googling everything, nothing worked for me.

    Fix: Change the theme in GDM, if someone can explain why this worked and the original theme not I would like to understand.
     

Share This Page