Fedora perfect desktop 7, updates wont download

Discussion in 'HOWTO-Related Questions' started by Mystical, Sep 22, 2007.

  1. Mystical

    Mystical New Member

    I followed everything in the guide, updates will not download, the box stays empty after a hour.

    I'm running on vmware and I'm sure that i had internet

    Also if you may, please tell me how to change the screen resolution at start up (it gets fine if i log in to my account but it's a bigger resolution at start up, user log in, etc)


    *edit: INstalling regular software works and downloads just not updates
    Last edited: Sep 23, 2007
  2. falko

    falko Super Moderator ISPConfig Developer

    Are there any errors in your log files?
  3. Mystical

    Mystical New Member

    If by install logs then no.

    I found a way around it by just going in to the terminal.
    And sometimes installing regular software wont work eirther. Maybe it's just the GUI.

    Also about the screen resolution question. I wanted to change it on log in and start up, and I also tried your guide for Compiz and when ever compiz starts I get this.


    And compiz doesn't work.

    (I tried going to display in the administration tool bar as root, but it doesn't seem like it wants to listen to the screen resolution and wants to keep at the highest possible)

    Is there a driver i need to download for compiz?
    Last edited: Sep 24, 2007
  4. tmick

    tmick New Member

    Do you Have Nvidia or ATI?
  5. Mystical

    Mystical New Member

    I tried nvidia but whenever I restart the GUI wont come up and when i typed in startx a error message comes up and it reconfigures everything.
  6. tmick

    tmick New Member

    Okay, what version of Nvidia do you have? Is it a GeForce 200 or some thing like that?
    If you run the command rpm -qa *nvidia* what are the results?
  7. Mystical

    Mystical New Member

    Nvidia GeForce 7200 GT

    rpm -ivh http://rpm.livna.org/livna-release-7.rpm
    yum install kmod-nvidia

    is what I used.

    And I already removed it since it screwed up so badly.

    EDIT : BTW i tried beryl also it logs me off every time i try to start the beryl manager. At least Compiz doesn't Log me off.....
    Last edited: Sep 24, 2007
  8. tmick

    tmick New Member

    What happens if you run these commands:
    su -
    yum install kmod-nvidia xorg-x11-drv-nvidia
    nvidia-config-display enable
    service nvidia restart
    and could you post your Xorg.conf file? It sounds like you have two issues, 1) You don't have the right driver installed 2) Your system isn't using the nv driver, try the above commands and let me know how it goes. You might want to check out this web site for additional instructions: http://www.diffingo.com/blog/content/blogcategory/34/33/
  9. Mystical

    Mystical New Member

    Nop, still doesn't work, here's my xorg.conf file

    # Xorg configuration created by livna-config-display
    Section "ServerLayout"
    	Identifier     "single head configuration"
    	Screen      0  "Screen0" 0 0
    	InputDevice    "Keyboard0" "CoreKeyboard"
    	InputDevice    "VMMouse" "CorePointer"
    Section "Files"
    	ModulePath   "/usr/lib/xorg/modules/extensions/nvidia"
    	ModulePath   "/usr/lib/xorg/modules"
    Section "ServerFlags"
    	Option	    "AIGLX" "on"
    Section "InputDevice"
    	Identifier  "Keyboard0"
    	Driver      "kbd"
    	Option	    "XkbModel" "pc105"
    	Option	    "XkbLayout" "us"
    Section "InputDevice"
    	Identifier  "VMMouse"
    	Driver      "vmmouse"
    	Option	    "Device" "/dev/input/mice"
    	Option	    "Emulate3Buttons" "yes"
    Section "Monitor"
    	Identifier   "Monitor0"
    	ModelName    "LCD Panel 1280x800"
    	HorizSync    31.5 - 90.0
    	VertRefresh  59.9 - 60.1
    	Option	    "dpms"
    Section "Device"
    	Identifier  "Videocard0"
    	Driver      "nvidia"
    	Option	    "AddARGBGLXVisuals" "True"
    	Option	    "DisableGLXRootClipping" "True"
    Section "Screen"
    	Identifier "Screen0"
    	Device     "Videocard0"
    	Monitor    "Monitor0"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    		Modes    "1280x800" "1280x720" "1152x864" "1024x768" "800x600" "640x480"
    Section "Extensions"
    	Option	    "Composite" "Enable"
    And here's the screen shot with the error when I tried to start the x server.


    Thanks for all your help.

    I followed everything here
    http://www.diffingo.com/blog/content/view/33/33/ (it said it's a requirement and I have no problems with this)
    and here
    Not yet here but will eventually
    Last edited: Sep 25, 2007
  10. tmick

    tmick New Member

    I think I found your problem, in the section "Device" it should be "Driver "nv"" not Driver "nvidia" use gedit to change that.
    su -
    gedit /etc/xorg.conf -> save as /etc/xorg.conf.old (just incase)
    then edit the device section and save as /etc/xorg.conf
    then post the results after the change
  11. Mystical

    Mystical New Member

    Still the same result as above when I tried to start the XSERVER.

    I've tried nv and nouveau.

    Should I just give up and try ATI?
    Last edited: Sep 26, 2007
  12. tmick

    tmick New Member

    I'll be honest, I am at a loss I have followed the instructions in the link I posted and was able to get mine working. At this point I can only suggest two more things, 1) See if Firewing has any ideas (he is on the team that develops the drivers for X the last I heard) 2) File a bug in Bugzilla. Other than that I have reached the extent of my knowledge, sorry I couldn't help you resolve this one. If you do find the secret to making it work please post it here someone else could benefit from it.
  13. Mystical

    Mystical New Member

    I don't have high hopes BUT i will try ATI.
    Again I don't have high hopes.
  14. mauriceh

    mauriceh New Member

  15. Mystical

    Mystical New Member

  16. tmick

    tmick New Member

    Do you have the kernel development package installed?
  17. mauriceh

    mauriceh New Member

    Ther eis a newer kernel and a newer nVidia driver

    First off Fedora 7 kernel 2.6.22-7 releases any minute.
    If you "just can't wait" go here:

    This is the release kernel, it just is not on the update repos (yet)
    Simply download the files for kernel, kernel-devel and kernel-libs.
    Make sure you get the ones for your arch
    To check what arch:
    uname -M

    For example I have an i386 install on an AMD Athlon64 X2, but I wanted 32 bit for browser plugin compatibility.
    As a result I have an i386 install, and it uses the i686 kernel ( 32 bit)

    rpm -ivh kernel-
    rpm -Uvh kernel-debug-
    rpm -Uvh kernel-headers-

    Optionally you may install the kernel debuginfo as well:
    rpm -Uvh kernel-debuginfo-

    Next, once that is installed, if you use the system updater and update/install
    "kmod-nvidia" you will get the driver 100.14.19
    Look here:
    There is a Fedora dependency for the 2.6.22-7 kernel so be sure to do the kernel first.

    But, I repeat BUT!!
    Do NOT install the nVidia drivers manually!
    Use yum, and then your dependencies will work properly.
    And, every time after you get a kernel update you will have to manually re-install (which sucks).

    yum update kmod-nvidia should do the trick

    Good luck!

Share This Page