Fedora/grub do not change bios nic name

Discussion in 'HOWTO-Related Questions' started by conductive, Sep 28, 2011.

  1. conductive

    conductive Member

    I was attempting a Fedora 15 perfect server but editing grub and rebooting do not change the nic name to eth0. My current name is eml

    Any ideas?

    Thanks
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What exactly did you change?

    Did you see any errors during boot?
     
  3. conductive

    conductive Member

    I was following the procedure, did not look for boot up errors and quit since I seem to keep going farther backwards everytime I attempt a different load.
    ____________________________________________________
    http://www.howtoforge.com/perfect-server-fedora-15-x86_64-ispconfig-3-p3
    Now we must configure Fedora to not use BIOS device names for our network interface anymore. Instead of p3p1, we need our good, old eth0 back (because otherwise ISPConfig's firewall will go crazy and block everything because it expects eth0 instead of p3p1). Open /etc/grub.conf...

    vi /etc/grub.conf

    ... and add biosdevname=0 to the kernel line:
    _____________________________________________________

    So far I have tried numerous loads of CentOS 6.0 ISPC3 and it will not parse my code or simple textbook code. I could not get any errors, verify directives or find anything in the manual on the subject.

    Fedora I could take or leave it seems to have some bloat but I do not care I just want to get something to work.

    I am currently trying Debian 6.0. I need a symbolic link or other since the uploaded pages do not come up. I have added DNS info and added ip addresses but still no go. The only thing adding an ip address does is give me the virutal boot error on apache restart. Ip address is also not responsive so it would appear that this would require adding it in the beginning of the procedure.

    So I think what I really need is a recommendation for the best server. so far the Cent0S 6.0 came the closest but the php was a real show stopper.

    Thanks for your help and keep up the good work!
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Do you use short PHP open tags in your PHP code? These are disabled by default in /etc/php.ini on CentOS 6.0; you can enable them there or use long PHP open tags in your code.

    The best distribution for ISPConfig 3 is Debian/Ubuntu. If you use the tutorials from http://www.ispconfig.org/ispconfig-3/documentation/ , you shouldn't run into any problems.
     
  5. conductive

    conductive Member

    open_short_tag = Off >>>>>On
    Is the clue that just made my weekend.
    I am so happy.

    I think I just got caught up into to many snfu's and when you really should edit a config file.

    The only question left here is where is the best place to make this change since the /etc/php.ini would be across the whole system.
    ------------------------------
    ------------------------------
    I still might not be out of the woods yet since display_erors = On will produce:

    Warning: require(): open_basedir restriction in effect. File() is not within the allowed path(s): (/var/www/clients/client1/web1/web:/var/www/clients/client1/web1/tmp:/var/www/mydomain.com/web:/srv/www/mydomain.com/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin) in /var/www/clients/client1/web1/web/home.php on line 2
    ------------------------------
    -------------------------------
    As far as the Debian goes I think I was one add additional Ip procedure away from making that happen. I do not know if it would be the same as in say the CentOS 5.6 guide or not but it seems to me that putting in IP addresses helps with serving the proper container as opposed to the default that was coming up for me.
    ---------------------
    :)
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Please adjust the open_basedir field on the Options tab of the website in ISPConfig.
     

Share This Page