[Fedora Core 5] I can´t login with FTP and MySQL

Discussion in 'Installation/Configuration' started by banaantje12, Sep 8, 2006.

  1. banaantje12

    banaantje12 New Member

    I installed "The Perfect Setup: Fedora Core 5".
    Now I changed the users prefix from "web[ID]_" to "" (no prefix).
    Now I added 5 hosting packages. And I allowed FTP and MySQL.
    Then I added a user and gave it a username and a password.
    Then I added an website and I get this message on the website:
    Code:
    This is the standard index of your website. You can easily delete it or replace it with another file. This is the index.html file in the web directory.
    
    For questions or problems please contact the server administrator. 
    Now I think I wanna upload my site (just to test FTP;) ).
    So I fill in my username and password.
    And then I get this message:
    Code:
    Could not connect as user ***************
    And I installed phpMyAdmin. I can´t login with phpMyAdmin to:(

    ---------------------------------------

    I don´t know if this is important but when I go to see a list of users I only see my default username and admispconfig
     
  2. willebanks

    willebanks New Member

    banaatje12

    Are you trying to use the web-ftp feature in ISPConfig or are you trying to connect via remote FTP?

    If you are trying remote ftp - Check your router if you have one and be sure you are forwarding port 21...

    if you are trying to use the web-ftp feature in ISPConfig it can be a little tricky at first. heres how I go about it.

    From the ISPConfig tool bar - Click on ISP Manager

    Click on Sites..find your sites name, click on it.

    look for the user & email tab, again click on it!

    Make sure you have a user! If not make one and make it the Administrator. Thats very important!

    Save everything and then go to web-ftp on the tool bar!

    The name of the website and the your user name should already be filled in! all you need to do is type in the password.

    let me know how it goes!

    Will
     
  3. banaantje12

    banaantje12 New Member

    Okay FTP is working now. But now I still can´t login with phpMyAdmin (I installed the module at ispconfig.org)

    But I can login as root user.
     
  4. Ben

    Ben ISPConfig Developer ISPConfig Developer

    So you can login via phpMyAdmin as root, but not with the mySQL Users you created foreach web?

    Could you please take a look in the "rights" tab of phpMyAdmin to see if all these users you created are displayed?
     
  5. banaantje12

    banaantje12 New Member

    It only shows root
     
  6. Ben

    Ben ISPConfig Developer ISPConfig Developer

    So the user table in the mysqldatabase contains only root?
    Hmm I would say ISPConfig could not create the users....
    Do you see other databases than mysql and maybe test? Because they should also be created by ISPConfig when creating a user...

    But did you really set up the database? Because in your first post you write sth. of creating the hosting package and enable mysql + ftp and add a user + website but nothing of mysql user.
    The ftp user comes with the email thing, but mysql user + database has to be created seperately...
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Ben is right, you must create the database and the MySQL user on the "Options" tab (of course you must enable MySQL before on the "Basis" tab.
     

Share This Page