Fedora Core 4: charset problem (UTF-8?)

Discussion in 'Server Operation' started by Pasco, Aug 22, 2005.

  1. Pasco

    Pasco New Member HowtoForge Supporter

    Hi 2gether,

    I have a charset problem with my Fedora Core 4 ISPConfig installation.

    Is it possible to choose which charset the ISPConfig Server uses? Or is that a non-ISPConfig subject? If yes, I'm sorry to ask here.

    I've already tried a lot of different settings with my php code ($setlocale) but with no sucess...I've got problems with all the ä, ü, ö, etc. (special swiss/german characters). I tried settings for the UTF-8 Charset.

    Thanks so much for your help,
    P@sco
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Do you have problems with swiss umlauts in the controlpanel too?
     
  3. Pasco

    Pasco New Member HowtoForge Supporter

    Yes I have. For example "Grösse" etc. in the statistics is hardly readable :rolleyes: .

    Do you have any idea how to solve this problem?

    Thx, p@sco
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    There is no solution yet, it is a problem only in Fedora. The only possible soution i see is to extend the scripts so that they replace the UTF-8 chars by the correct chars in the output of the commandline utilitys displayed in the web interface.
     
  5. Pasco

    Pasco New Member HowtoForge Supporter

    How do I do that? Can you give me a hint?
     
  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    The files are:

    /home/admispconfig/ispconfig/lib/plugins/check_*.plugin.php
     

Share This Page