fedora 9 vmware web managment help

Discussion in 'HOWTO-Related Questions' started by jmbrown, Jun 2, 2008.

  1. jmbrown

    jmbrown New Member

    Hi, I installed Fedora 9 with the 64 bit version, and installed vmware server as well as the web management tool fine. If I go to the server:8333 I get the login page. However I cannot log in! I have tried using both my local account as well as root and the passwords for each. I also logged in remotely to the server with both accounts to make sure they work which they do. So I just can't log in once I see the vmware management interface screen! Any ideas what to do? Is this a known problem?

    I checked /var/log/vmware-mui/error_log and I always get the same error:

    vmware::management:SxLogin line 177: -4: Permission denied: Login (username/password) incorrect

    I checked the /etc/vmware/pam.d/vmware-authd and its the following

    auth sufficient %pamdir%/pam_unix2.so shadow nullok
    (it then has 3 more lines very similar calling different pam unix files)

    I tried changing the pathway of these files to lib64/security & /usr/lib/vmware/lib/libpam.so.0/security but niether worked (I found the same pam files in both of these places). So I have since changed the file back to the original.

    so at this point I am at a loss, any help would be greatly appreciated.
  2. falko

    falko Super Moderator ISPConfig Developer

    Did you disable SELinux?
  3. jmbrown

    jmbrown New Member

    yes, I tried that as well and it had no effect. I tried installing it without and with selinux and the firewall up, so that is or at least should not be the problem, I thought it might be something with connecting it to pam, but I am just unsure at this point. Any help would be greatly appreciated.
  4. falko

    falko Super Moderator ISPConfig Developer

    Could you back up /etc/vmware/pam.d/vmware-authd and then replace its contents with the content of, for example, /etc/pam.d/ssh?

Share This Page