Fedora 9 Server How-to dead on first Reboot

Discussion in 'HOWTO-Related Questions' started by coldspring, May 29, 2008.

  1. coldspring

    coldspring New Member


    I'm new at this so please forgive me it I missed something obvious.

    Starting with a new machine I followed the Fedora 9 Perfect Server How-to with one exception.
    When installing Fedora 9 I included Office applications along with the other suggested server and development applications.​

    I followed the install exactly and never even touched anything to do with the office applications. I also installed ISPConfig.

    I tested everything before rebooting my machine and everything, including ISPConfig worked as is was suppose to.

    I then rebooted the machine and that is where I ran into trouble.

    The machine seems to boot fine but then does not finish at the login page. Instead the machine boots to the desk top background image, places a control bar at the bottom of screen with no controls or object in it and then stops!

    I can't do any thing with the machine! I can not get to a a shell window, I can not get to a command line. The only thing I could do was a complete reinstall starting from reinstalling Fedora 9. When I did, the exact same thing happen.

    What am I doing wrong?

    Thanks for the help

  2. falko

    falko Super Moderator ISPConfig Developer

    Open /etc/shells and remove the /SENDMAIL/ANY/SHELL line from it.
  3. coldspring

    coldspring New Member


    Thank you for the help, yet again.

    Regarding you last suggestion;

    How do I get to a command line? At this point all I see is desktop background graphic. The system seem to boot to this point. I never see a login screen, I cannot get to a termial or cannot I figure out how to exit out of the windows GUI or start the system without the xwindows gui. The system does not seem to take any input form the key board or mouse.

    Do I have to go through a complete Fedora install and redo the Server How-to again?

  4. coldspring

    coldspring New Member


    As soon as I posted my previous question, I figured it out. I used a Fedora 9 rescue disk, now named netinstall.

    I went into rescue mode, edited the /etc/shells files as you suggested and I can now log on to the system.

    Now I have to figure out how to use all these great tools you helped me install.

    Thanks for the help.


Share This Page