Fedora 9 64Bit & VMWare

Discussion in 'HOWTO-Related Questions' started by reaper5oh, Jul 31, 2008.

  1. reaper5oh

    reaper5oh New Member

    Hey Guys,

    I have Just installed Fedora 9 64Bit. I have completely updated the system using "yum update". I did the update yesterday so I have the absolute latest updates. I rebooted the machine, logged in and started gnome.

    I have now been following the "How To Install VMWare Server (Version 1.0.6) On A Fedora 9 Desktop" Tutorial.

    I followed the instructions carefully and during the con-fig found that I was missing some required library files. I located the Fedora 9 64 Bit RPM version of these files (There were about 6 files) and installed them. I ran through the rest of the setup entered the serial number and the installation and setup was complete. When I try and launch VMWare using the VMWare Server Console the application icon appears on my task bar and then shortly after just disappears and nothing loads.

    Any advice would be great... I want to run about 3 VM's on this machine for difference server related purposes.

    My Hardware:
    CPU: Intel Dual Core E2200
    RAM: 4GB DDR2
    HD: 500GB SATA 7200RPM

    Thank you in Advance,
  2. falko

    falko Super Moderator ISPConfig Developer

    Can you open a terminal and run
    ? Do you see any errors then?
  3. reaper5oh

    reaper5oh New Member

    Hey Sorry for late reply have been away...

    I have formatted and started again with a bigger drive. Im still using 64 Bit Fedora 9.

    I installed VMware using the RPM and when I launch config I get the following message:

    "# /usr/bin/vmware-config.pl
    The correct version of one or more libraries needed to run VMware Server may be
    missing. This is the output of ldd /usr/bin/vmware:
    linux-gate.so.1 => (0x00110000)
    libm.so.6 => /lib/libm.so.6 (0x00120000)
    libdl.so.2 => /lib/libdl.so.2 (0x00149000)
    libpthread.so.0 => /lib/libpthread.so.0 (0x0014e000)
    libX11.so.6 => not found
    libXtst.so.6 => not found
    libXext.so.6 => not found
    libXt.so.6 => not found
    libICE.so.6 => not found
    libSM.so.6 => not found
    libXrender.so.1 => not found
    libz.so.1 => not found
    libc.so.6 => /lib/libc.so.6 (0x00aa2000)
    /lib/ld-linux.so.2 (0x00a82000)

    This program cannot tell for sure, but you may need to upgrade libc5 to glibc
    before you can run VMware Server."

    Is there an additional package I should install... My system tells me I have the latest version of glibc installed. I don't think I have libc5 and could not find it?
    Last edited: Aug 7, 2008
  4. reaper5oh

    reaper5oh New Member

    I fixed the problem above and when i type "vmware" i get the following:

    # vmware
    /usr/share/themes/Nodoka/gtk-2.0/gtkrc:37: error: unexpected character `@', expected string constant
    Locking assertion failure. Backtrace:
    #0 /usr/lib/libxcb-xlib.so.0 [0xa79767]
    #1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_unlock+0x31) [0xa79831]
    #2 /usr/lib/libX11.so.6(_XReply+0x244) [0x192f64]
    #3 /usr/lib/vmware/lib/libXrender.so.1/libXrender.so.1(XRenderQueryFormats+0x109) [0x31f969]
    #4 /usr/lib/vmware/lib/libXrender.so.1/libXrender.so.1(XRenderFindFormat+0x4c) [0x31ff4c]
    #5 /usr/lib/vmware/lib/libgdk-x11-2.0.so.0/libgdk-x11-2.0.so.0 [0x4e8180]
    #6 /usr/lib/vmware/lib/libgdk-x11-2.0.so.0/libgdk-x11-2.0.so.0 [0x4e8d2c]
    #7 /usr/lib/vmware/lib/libgdk-x11-2.0.so.0/libgdk-x11-2.0.so.0(gdk_draw_pixbuf+0x270) [0x4b8c14]
    #8 /usr/lib/vmware/lib/libgdk-x11-2.0.so.0/libgdk-x11-2.0.so.0 [0x4c524f]
    #9 /usr/lib/vmware/lib/libgdk-x11-2.0.so.0/libgdk-x11-2.0.so.0(gdk_draw_pixbuf+0x270) [0x4b8c14]
    #10 /usr/lib/vmware/lib/libgdk-x11-2.0.so.0/libgdk-x11-2.0.so.0(gdk_pixbuf_render_pixmap_and_mask_for_colormap+0x255) [0x4c4b34]
    #11 /usr/lib/vmware/lib/libgtk-x11-2.0.so.0/libgtk-x11-2.0.so.0 [0x7bd298]
    #12 /usr/lib/vmware/lib/libgtk-x11-2.0.so.0/libgtk-x11-2.0.so.0 [0x7bd586]
    #13 /usr/lib/vmware/lib/libgtk-x11-2.0.so.0/libgtk-x11-2.0.so.0 [0x7bf77e]
    #14 /usr/lib/vmware/lib/libgobject-2.0.so.0/libgobject-2.0.so.0(g_cclosure_marshal_VOID__VOID+0xd1) [0x3ea459]
    #15 /usr/lib/vmware/lib/libgobject-2.0.so.0/libgobject-2.0.so.0 [0x3d23a1]
    #16 /usr/lib/vmware/lib/libgobject-2.0.so.0/libgobject-2.0.so.0(g_closure_invoke+0x1b1) [0x3d2076]
    #17 /usr/lib/vmware/lib/libgobject-2.0.so.0/libgobject-2.0.so.0 [0x3e96eb]
    #18 /usr/lib/vmware/lib/libgobject-2.0.so.0/libgobject-2.0.so.0(g_signal_emit_valist+0x91e) [0x3e8d46]
    #19 /usr/lib/vmware/lib/libgobject-2.0.so.0/libgobject-2.0.so.0(g_signal_emit+0x38) [0x3e90b8]
    Locking assertion failure. Backtrace:
    #0 /usr/lib/libxcb-xlib.so.0 [0xa79767]
    #1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_lock+0x2e) [0xa7990e]
    #2 /usr/lib/libX11.so.6 [0x192109]
    #3 /usr/lib/libX11.so.6(XAddExtension+0x2c) [0x17423c]
    #4 /usr/lib/vmware/lib/libXft.so.2/libXft.so.2(_XftDisplayInfoGet+0x77) [0x330ed7]
    #5 /usr/lib/vmware/lib/libXft.so.2/libXft.so.2 [0x32f8b1]
    #6 /usr/lib/vmware/lib/libXft.so.2/libXft.so.2 [0x32fd39]
    #7 /usr/lib/vmware/lib/libXft.so.2/libXft.so.2(XftDrawPicture+0x10) [0x32fec0]
    #8 /usr/lib/vmware/lib/libgdk-x11-2.0.so.0/libgdk-x11-2.0.so.0 [0x4e69b6]
    #9 /usr/lib/vmware/lib/libgdk-x11-2.0.so.0/libgdk-x11-2.0.so.0 [0x4e8d75]
    #10 /usr/lib/vmware/lib/libgdk-x11-2.0.so.0/libgdk-x11-2.0.so.0(gdk_draw_pixbuf+0x270) [0x4b8c14]
    #11 /usr/lib/vmware/lib/libgdk-x11-2.0.so.0/libgdk-x11-2.0.so.0 [0x4c524f]
    #12 /usr/lib/vmware/lib/libgdk-x11-2.0.so.0/libgdk-x11-2.0.so.0(gdk_draw_pixbuf+0x270) [0x4b8c14]
    #13 /usr/lib/vmware/lib/libgdk-x11-2.0.so.0/libgdk-x11-2.0.so.0(gdk_pixbuf_render_pixmap_and_mask_for_colormap+0x255) [0x4c4b34]
    #14 /usr/lib/vmware/lib/libgtk-x11-2.0.so.0/libgtk-x11-2.0.so.0 [0x7bd298]
    #15 /usr/lib/vmware/lib/libgtk-x11-2.0.so.0/libgtk-x11-2.0.so.0 [0x7bd586]
    #16 /usr/lib/vmware/lib/libgtk-x11-2.0.so.0/libgtk-x11-2.0.so.0 [0x7bf77e]
    #17 /usr/lib/vmware/lib/libgobject-2.0.so.0/libgobject-2.0.so.0(g_cclosure_marshal_VOID__VOID+0xd1) [0x3ea459]
    #18 /usr/lib/vmware/lib/libgobject-2.0.so.0/libgobject-2.0.so.0 [0x3d23a1]
    #19 /usr/lib/vmware/lib/libgobject-2.0.so.0/libgobject-2.0.so.0(g_closure_invoke+0x1b1) [0x3d2076]
    vmware: xcb_lock.c:77: _XGetXCBBuffer: Assertion `((int) ((xcb_req) - (dpy->request)) >= 0)' failed.

    Also I had to turn of vmware networking because it was crashing the install... am I better to just use the Virtualization built into Fedora 9 64Bit?
  5. falko

    falko Super Moderator ISPConfig Developer

    I'm not sure how to fix this. :(
  6. heperez

    heperez New Member

    I have the same errors when i installed vmware 1.0.6-91.... in Fedora 9.
    My server is a PowerEdge Dell 2950 III, 64 bits with 2 disc and Hw Raid 0.

    The fix i tried to resolv the problem with the not found libraries was

    ln -s /usr/lib64/libX11.so.6.2.0 /lib/libX11.so.6
    ln -s /usr/lib64/libXtxt.so.6.1.0 /lib/libXtst.so.6
    ln -s /usr/lib64/libXext.so.6.4.0 /lib/libXext.so.6
    ln -s /usr/lib64/libXt.so.6.0.0 /lib/libXt.so.6
    ln -s /usr/lib64/kubUCE.so.63.0 /lib/libICE.so.6
    ln -s /usr/lib64/libSM.so.6.0.0 /lib/libSM.so.6
    ln -s /usr/lib64/libXrender.so.1.3.0 /lib/libXrender.so.1
    ln -s /usr/lib64/libz.so.1.2.3 /lib/libz.so.1

    but still not found. I don't know why.
    Anyway, i continue trying to install but when the procedure tried to generate vmware-cmd abort because in the script there were an invalid substitution.
    Then, when i execute "vmware" alone, abort with the following error:
    "error while loading sharing libraries: libX11.so.6: wrong ELF class: ELFCLASS64"

    I don't know what to do.
    In vmware.com there is not a version for 64bits systems.

    Any help will be apreciated.
    (Sorry for my english).
  7. heperez

    heperez New Member

    I did some research and finally found the way to install vmware server and i will post my solution if it helps for other people.

    The problem was thar vmware server needs 32 bits libraries, and so, you must provide this ones.

    For some people the next sentence will resolv his trouble.
    # yum install libXtst.i386 and so on

    But it didn't function for me. When i executed the command above, it told me that can't found this package.
    So, i went to /etc/yum.repos.d and create the file fedora-i386.repo with the following contain (this will create the i386 repository):

    name=Fedora $releasever - i386
    name=Fedora $releasever - i386 - Updates
    Now i add the next line in /etc/yum.conf:


    But i not sure if really it is necesary. You may probe this and if so, please, tell me.

    Now i'm ready to install the 386 libraries:

    # yum install libX11.so.6 libXtst.so.6 libXext.so.6 \
    libXt.so.6 libICE.so.6 libSM.so.6 libXrender.so.1 libz.so.1 libXi.so.6

    Then i installed vmware server without any further problem.
    (Off course, i removed the symbolic links created in the above post).
  8. heperez

    heperez New Member

    Now. When i tried to execute vmware console from a remote machine, i had problems again.
    New research and found where was the problem.
    The pam libraries.

    # yum install pam.x86_64 pam.i386 pam-devel.x86_64 pam-devel.i386
    # cd /etc/pam.d
    # cp vmware-authd vmware-authd.original (not necesary, but....)
    # vi vmware-authd

    and substitute /usr/lib/vmware/lib/libpam.so.0/security by /lib/security
    then also substitute pam_unix2.so by pam_unix.so

    After all of this, i can connect with my remote vmwere server console.
  9. tiesel

    tiesel New Member

    Summarizing, the following step has proven to work on a F9 x86_64 installation
    with #1 SMP x86_64 x86_64 x86_64 GNU/Linux :

    yum install libX11.i386 libXext.i386 libXi.i386 zlib.i386 libXtst.i386 \
    libICE.i386 libSM.i386 libXrender.i386 libXt.i386 \
    xinetd kernel-devel pam.i386 pam-devel.i386 gtk2.i386

    May it be helpful :)

Share This Page