Fedora 8 - Mysql and Postfix problems when installing ISPConfig-2.2.18

Discussion in 'Installation/Configuration' started by juanfra77, Jan 7, 2008.

  1. juanfra77

    juanfra77 New Member

    I found some problems when I was following your instructions to install ISPConfig on a brand new Linux Server. I am using Fedora 8. Is it possible that you read below and help me out? Your instructions were clear and useful at every step. I am now two steps from the end and then I can start installing ISPConfig. I am affraid I have to get this two things fixed before I proceed with the installation.

    Thanks very much.

    [email protected]


    enabling root password for MySql

    [root@linuxserver sbin]# mysqladmin -u juanfra77 password changeme
    mysqladmin: connect to server at 'localhost' failed
    error: 'Access denied for user 'juanfra77'@'localhost' (using password: NO)'

    [root@linuxserver sbin]# mysqladmin -h server1.example.com -u root password changeme
    mysqladmin: connect to server at 'server1.example.com' failed
    error: 'Unknown MySQL server host 'server1.example.com' (1)'
    Check that mysqld is running on server1.example.com and that the port is 3306.
    You can check this by doing 'telnet server1.example.com 3306'


    Enabling Post Fix

    postconf -e 'smtpd_sasl_local_domain ='
    postconf -e 'smtpd_sasl_auth_enable = yes'
    postconf -e 'smtpd_sasl_security_options = noanonymous'
    postconf -e 'broken_sasl_auth_clients = yes'
    postconf -e 'smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination'
    postconf -e 'inet_interfaces = all'
    postconf -e 'mynetworks ='

    I get errors saying postconf is not found. I run it from sbin

    [root@linuxserver sbin]# ./postconf -e 'smtpd_sasl_auth_enable = yes'
    bash: ./postconf: No such file or directory

    The same problem here, postconf is not recognize command.

    Next we configure Postfix for TLS:

    postconf -e 'smtpd_tls_auth_only = no'
    postconf -e 'smtp_use_tls = yes'
    postconf -e 'smtpd_use_tls = yes'
    postconf -e 'smtp_tls_note_starttls_offer = yes'
    postconf -e 'smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key'
    postconf -e 'smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt'
    postconf -e 'smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem'
    postconf -e 'smtpd_tls_loglevel = 1'
    postconf -e 'smtpd_tls_received_header = yes'
    postconf -e 'smtpd_tls_session_cache_timeout = 3600s'
    postconf -e 'tls_random_source = dev:/dev/urandom'
    postconf -e 'smtpd_sasl_authenticated_header = yes'

  2. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    netstat -tap

    Sounds like a path problem. Please make sure that you log in directly as root; logging in as another user and then doing a su to root might be the problem.
  3. juanfra77

    juanfra77 New Member

    There are some points still not working, for the rest it works fine. Thanks.

    Hi falko, thanks very much for your quick response. I had a few issues I am starting to wonder if it is just me who is having these problems or other people too.

    A) I am still having trouble enabling my password root password for mysql. Following your instructions, I used:

    mysqladmin -u root password changeme (this command worked out great)
    mysqladmin -h server1.example.com -u root password (did not work)

    This was the outcome.

    [root@fedora-8-server named]# mysqladmin -h fedora-8-server -u root password changeme
    mysqladmin: connect to server at 'fedora-8-server' failed
    error: 'Access denied for user 'root'@'fedora-8-server' (using password: NO)'

    As you see, the problem persists. I logged in as root directly. If the access is denied to root, who can do it then? This is a bit weird, because mysql is running.

    You also asked me to try netstat –tap, and here is the outcome.

    [root@fedora-8-server named]# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:mysql *:* LISTEN 2828/mysqld
    tcp 0 0 *:50636 *:* LISTEN 1611/rpc.statd
    tcp 0 0 *:sunrpc *:* LISTEN 1592/rpcbind
    tcp 0 0 localhost.localdomai:domain *:* LISTEN 2515/named
    tcp 0 0 localhost.localdomain:ipp *:* LISTEN 1942/cupsd
    tcp 0 0 localhost.localdomain:rndc *:* LISTEN 2515/named
    tcp 0 0 localhost.localdomain:smtp *:* LISTEN 1817/sendmail: acce
    tcp 0 0 localhost6.localdoma:domain *:* LISTEN 2515/named
    tcp 0 0 *:ssh *:* LISTEN 1794/sshd
    tcp 0 0 localhost6.localdomain:rndc *:* LISTEN 2515/named
    tcp 0 0 fedora-8-server:ssh ::ffff: ESTABLISHED 2413/0

    B) You had a great idea to introduce the set of postconf commands. I logged in as root from the first time, and it worked great. Maybe the article should also indicate, as other people may find themselves with the same problem.

    C) Once you finish installing PostFix, they ask you try the below command to test that SMTP-AUTH and TLS. I didn’t error messages during its configuration, only when I try if it works, the session times out.

    [root@fedora-8-server sbin]# telnet localhost 25
    Connected to localhost.
    Escape character is '^]'.
    220 Fedora-8-server ESMTP Postfix
    421 4.4.2 Fedora-8-server Error: timeout exceeded
    Connection closed by foreign host.

    As you can imagine, the command ehlo localhost doesn’t work either.

    For the rest, I managed to install ICP successfully and it works fine. Thanks very much for your indications.
  4. falko

    falko Super Moderator ISPConfig Developer

    This means you have the wrong hostname in the mysql.user table. You can fix it as shown in chapter 8 on http://www.howtoforge.com/perfect_server_opensuse10.3_p4 , starting with

    This is where you must enter
    ehlo localhost
    If you don't do this and wait too long, you get the timeout:


Share This Page