Fedora 6 & VMware server

Discussion in 'HOWTO-Related Questions' started by chejose, Mar 14, 2007.

  1. chejose

    chejose New Member

    I did an installation of VMware server on Fedora 6, following the "Howto" instructions. All went well, with no errors, including the configuration. But..

    1 - It takes 4.5 minutes for the console to open (during various trial runs).

    2 - I wanted to set up a Win 2K installation. But it opens up to a black screen with no cursor. In other words, no way to process the created HD. I tried it twice, both with the same result, so there are two incomplete installations waiting. The row of buttons is also faded out.

    I am fairly new to Linux, so please put any answer in "simple" terms.
    Many thanks
     
  2. falko

    falko Super Moderator

    Are there any errors in the logs in the /var/log directory? What's the output of
    Code:
    uname -a
    ?
     
  3. chejose

    chejose New Member

    Thanks for getting back to me!

    I looked through the log, and only found the following that is close to an error.The rest seems to have gone OK


    Mar 15 07:36:11: app| UndopointGetSuspendState failed Failed to read from snapshot helper fd.
    Mar 15 07:36:11: app| .
    Mar 15 07:36:11: app| UndopointHasIndependentDisks failed Failed to read from snapshot helper fd.


    [root@localhost jose]# uname -a
    Linux localhost.localdomain 2.6.20-1.2925.fc6 #1 SMP Sat Mar 10 19:15:16 EST 2007 i686 i686 i386 GNU/Linux

    Jose
     
  4. chejose

    chejose New Member

    Falko:

    I just made another try at opening VMserver and the consel simply did not open. There was nothing in the log for the attempt.

    But looking at the log, I realize now that it is the boot up sesion that I made this morning, and not the last time I tried to open the consel. The end of the log says:

    Mar 15 07:36:11: app| VM suddenly changed state: poweredOff.
    Mar 15 07:36:11: app| VM suddenly changed state: poweredOff.
    Mar 15 07:36:11: app| impersonate Impersonate_Undo called when refCount == 0
    Mar 15 07:36:11: app| Serverd hostname: localhost.localdomain
    Mar 15 07:36:11: app| Setting up serverd discovery channel for vmxes
    Mar 15 07:36:11: app| Successfully set up serverd discovery channel for vmxes
    Mar 15 07:36:11: app| vmware-serverd entering main loop.
    Mar 15 07:36:11: app| Signal 15 caught. Requesting shutdown.
    Mar 15 07:36:11: app| Shutting down vmserverd (0).

    Whether that means anything or not I have no idea. But it looks like I am at zero right now.
    Jose
     
  5. nomadic

    nomadic New Member

    Thanks for tutorial

    Excellent tutorial - thank you.
    Two minor issues I came across

    w32codec
    - w32codec was not available from atrpms using tutorial instructions.
    - checked atrpms site and w32codec was not listed as a fedora 6 package, tho
    I did find it when I listed all packages by name
    - I downloaded and installed it separately from atrpms site.

    Nvu
    I think the line
    rpm -ivh xorg-x11-deprecated-libs-6.8.2-1.EL.13.37.5.i386.rpms
    should end with .rpm rather than .rpms ?

    Again, many thanks

    nomadic
     
  6. falko

    falko Super Moderator

    Is this the same kernel that was installed when you installed VMware? Or is it a newer one?
     
  7. falko

    falko Super Moderator

    That's right. I've corrected it in the tutorial. :)
     
  8. chejose

    chejose New Member

    Falko
    Since there are downloads almost every day for system adjustments, it could be that the kernal has been changed since then.
    Yesterday I could not even open VMserver, but noticed today that in the boot list it said that the config file should be run again. So I did it, and it is full of errors. After dioing it literally froze Fedora and I had to hit the "panic button" since it would not reboot. Don't know if it is possible to make sense of it, but here goes:

    Using 2.6.x kernel build system.
    make: Entering directory `/tmp/vmware-config0/vmmon-only'
    make -C /lib/modules/2.6.20-1.2925.fc6/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
    make[1]: Entering directory `/usr/src/kernels/2.6.20-1.2925.fc6-i686'
    CC [M] /tmp/vmware-config0/vmmon-only/linux/driver.o
    In file included from /tmp/vmware-config0/vmmon-only/linux/driver.c:80:
    /tmp/vmware-config0/vmmon-only/./include/compat_kernel.h:21: error: expected declaration specifiers or ‘...’ before ‘compat_exit’
    /tmp/vmware-config0/vmmon-only/./include/compat_kernel.h:21: error: expected declaration specifiers or ‘...’ before ‘exit_code’
    /tmp/vmware-config0/vmmon-only/./include/compat_kernel.h:21: warning: type defaults to ‘int’ in declaration of ‘_syscall1’
    make[2]: *** [/tmp/vmware-config0/vmmon-only/linux/driver.o] Error 1
    make[1]: *** [_module_/tmp/vmware-config0/vmmon-only] Error 2
    make[1]: Leaving directory `/usr/src/kernels/2.6.20-1.2925.fc6-i686'
    make: *** [vmmon.ko] Error 2
    make: Leaving directory `/tmp/vmware-config0/vmmon-only'
    Unable to build the vmmon module.

    For more information on how to troubleshoot module-related problems, please
    visit our Web site at "http://www.vmware.com/download/modules/modules.html" and
    "http://www.vmware.com/support/reference/linux/prebuilt_modules_linux.html".

    Execution aborted.

    I suspect that I must re-install or something similar, but I am afraid that I am lost for the moment.
    Thanks for either suggesting a solution or telling me to give up. :)
    Jose
     
  9. till

    till Super Moderator

    Please check at vmware if there is a newer package. It loks that this package either contains a bug or is not compatible with the kernel installed on your server.
     
  10. chejose

    chejose New Member

    Till:
    Thanks for the suggestion. I had just recently downloaded the VMserver package, but it could easily be broken. I guess I will uninstall VM server once more, and will attempt another fresh installation. If it doesn't work this time, I give up.
    José
     

Share This Page