Fedora 6 - Install failed

Discussion in 'Installation/Configuration' started by Animazing, Nov 24, 2007.

  1. Animazing

    Animazing New Member

    Hi Guys,

    I have tried to install ISPConfig 5 times now and still no luck. I get the same error everytime.

    Code:
    Connected successfully to MySQL server
    ./setup2: line 1099:  3512 Segmentation fault      /root/ispconfig/php/php -q ./install.php
    Restarting some services...
    httpd not running, trying to start
    Shutting down postfix:                                     [  OK  ]
    Starting postfix:                                          [  OK  ]
    Shutting down proftpd:                                     [  OK  ]
    Starting proftpd:                                          [  OK  ]
    Starting ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl startssl: httpd started
    
    Warning: include(/home/admispconfig/ispconfig/lib/config.inc.php): failed to open stream: No such file or directory in /root/ispconfig/scripts/lib/config.inc.php on line 30
    
    Warning: include(): Failed opening '/home/admispconfig/ispconfig/lib/config.inc.php' for inclusion (include_path='.:') in /root/ispconfig/scripts/lib/config.inc.php on line 30
    /etc/rc.d/init.d/ispconfig_server: line 39:  3807 Segmentation fault      /root/ispconfig/php/php -q /root/ispconfig/scripts/shell/firewall.php
    ISPConfig system is now up and running!
    
    Can anybody point me in the right direction? What does a segmentation fault mean?

    Regards
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you remove the directories:

    /home/admispconfig

    and /root/ispconfig after every installation attempt? If not, the problem above has been caused by not removing the directories.
     
  3. Animazing

    Animazing New Member

    Yeah i removed all the dirs (well I did the last 4 times ;))
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Could be a hardware problem. Did you check your RAM (you can do this with memtest86, for example: http://www.memtest.org/ ).
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    And you followed exactly the fedora installation guide (perfect setup howto)?

    If yes, then you have most likely a hardware problem, e.g. on the mainboard or ram. If not, please follow exactly the installation instructions for your fedora version.
     
  6. Animazing

    Animazing New Member

    I'm hiring a dedicated server so memtest is not really an option unless i wanna travel to the datacenter (or is there an other way?)

    I followed the perfect setup for fedora core 6 so that shouldn't be it :/

    Is there some low-level error I could make that would result in such an error? A typo in the ssl cerftificate or something silly like that?
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Did you accept the default values (by pressing ENTER), or did you type in oyur own values?
     
  8. Animazing

    Animazing New Member

    I typed my own values 2 out of the 5 times. Is that a bad thing?
     
  9. Animazing

    Animazing New Member

    At a certain point during the installation ispconfig asks for a hostname and domain. Can my answers at that point give me the errors?
     
  10. falko

    falko Super Moderator ISPConfig Developer

    I'd accept the default values now to see if that makes a difference.
     
  11. falko

    falko Super Moderator ISPConfig Developer

    What did you type in?
     
  12. Animazing

    Animazing New Member

    I tried it again accepting all the default answers, no luck.

    I used control as hostname and brightlight-ict.nl as domain.
     
  13. falko

    falko Super Moderator ISPConfig Developer

    Was the error message different than the last time?
     
  14. Animazing

    Animazing New Member

    Nope it was the same :(
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    Please ask the staff at the datacenter to test the memory for you. I guess that if you rented the server from them, they will have to make sure that the hardware is fine. Segmentation faults are often caused by hardware problems as falko mentioned.
     
  16. Animazing

    Animazing New Member

    Ok so I finally got word from my host and there are no memory errors.

    Does anybody got an other idea what could be wrong?
     

Share This Page