Fedora 5 pureftpd mysql authentication error

Discussion in 'HOWTO-Related Questions' started by unclecameron, Sep 15, 2006.

  1. unclecameron

    unclecameron New Member

    Hi all,

    I'm running Fedora Core 5, ftp logs in anonymously but can't upload, system verifies username and creates home/user but won't authenticate. SELinux and firewall are disabled. BTW, great site, great help, let me know how I can support you guys :)

    Details:
    ftp connection attempt:
    -----------------------
    Status: Connecting to 192.168.2.143 ...
    Status: Connected with 192.168.2.143. Waiting for welcome message...
    Response: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
    Response: 220-You are user number 1 of 500 allowed.
    Response: 220-Local time is now 08:42. Server port: 21.
    Response: 220-IPv6 connections are also welcome on this server.
    Response: 220 You will be disconnected after 15 minutes of inactivity.
    Command: USER unclecameron
    Response: 331 User unclecameron OK. Password required
    Command: PASS ********
    Error: Disconnected from server
    Error: Unable to connect!
    --------------------------------

    query from mysql db pureftpd/ftpd
    ---------------------------------
    user unclecameron
    status 1
    Password d282b64578d46bd539cdb47c36.....
    Uid 2001
    Gid 2001
    Dir /home/unclecameron
    everything else = 0
    --------------------------

    /etc/pure-ftpd/pure-ftpd.conf
    -----------------------------
    ChrootEveryone yes
    BrokenClientsCompatibility no
    MaxClientsNumber 500
    Daemonize yes
    MaxClientsPerIP 100
    VerboseLog yes
    DisplayDotFiles yes
    AnonymousOnly no
    NoAnonymous no
    SyslogFacility ftp
    DontResolve yes
    MaxIdleTime 15
    MySQLConfigFile /etc/pure-ftpd/pureftpd-mysql.conf
    PAMAuthentication yes
    AnonymousCanCreateDirs no
    MaxLoad 4
    ntiWarez yes
    Umask 133:022
    MinUID 500
    AltLog clf:/var/log/pureftpd.log
    CreateHomeDir yes
    CustomerProof yes
    ----------------------------

    /etc/pure-ftpd/pureftpd-mysql.conf
    -----------------------------------

    MYSQLServer localhost
    MYSQLSocket /var/lib/mysql/mysql.sock
    MYSQLUser pureftpd
    MYSQLPassword ftpd
    MYSQLDatabase pureftpd
    MYSQLCrypt md5
    MYSQLGetPW SELECT Password FROM ftpd WHERE User="\L" AND status="1" AND (ipaccess = "*" OR ipaccess LIKE "\R")
    MYSQLGetUID SELECT Uid FROM ftpd WHERE User="\L" AND status="1" AND (ipaccess = "*" OR ipaccess LIKE "\R")
    MYSQLGetGID SELECT Gid FROM ftpd WHERE User="\L"AND status="1" AND (ipaccess = "*" OR ipaccess LIKE "\R")
    MYSQLGetDir SELECT Dir FROM ftpd WHERE User="\L"AND status="1" AND (ipaccess = "*" OR ipaccess LIKE "\R")
    MySQLGetQTAFS SELECT QuotaFiles FROM ftpd WHERE User="\L"AND status="1" AND (ipaccess = "*" OR ipaccess LIKE "\R")
    MySQLGetQTASZ SELECT QuotaSize FROM ftpd WHERE User="\L"AND status="1" AND (ipaccess = "*" OR ipaccess LIKE "\R")
    MySQLGetBandwidthUL SELECT ULBandwidth FROM ftpd WHERE User="\L"AND status="1" AND (ipaccess = "*" OR ipaccess LIKE "\R")
    MySQLGetBandwidthDL SELECT DLBandwidth FROM ftpd WHERE User="\L"AND status="1" AND (ipaccess = "*" OR ipaccess LIKE "\R")
    ------------------------------------

    There's nothing in /var/log/pureftpd.log

    1. Is there a way I can change to simpler authentication just see if I can get it working?
    2. Is there any way I can test the current authentication to see what password mysql is really seeing, and if it matches the user password?
    3. I normally work in Debian, but there are no RAID drivers for a Dell Poweredge 1850, so I went with FC5.

    Thanks,
    Cameron Camp
    San Diego
     
  2. falko

    falko Super Moderator ISPConfig Developer

  3. unclecameron

    unclecameron New Member

    Yeah, that's the tutorial I used.

    Thanks,
    Cameron
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Is there anything in the other logs in /var/log?
     
  5. unclecameron

    unclecameron New Member

    no, nothing in pureftpd.log, mysqld.log or any other log file that looked related.
    Thanks,
    Cameron
     
  6. sayfanet

    sayfanet New Member

    i also need ftpd mysql solution.

    i have tried to install proftpd - mysql on fc5 but it gives signal15 and doesnt start.

    tried everything. entered root password on proftpd.conf.

    what do you recommend me? is pureftpd easy to install?
     
  7. unclecameron

    unclecameron New Member

    Yeah, I had to get something up and running, and couldn't make proftpd work either, I installed

    yum install proftpd*

    which installed proftpd and proftpd-mysql, but I did:

    /etc/init.d/proftpd start

    and it failed, no matter what I edited with the configuration file proftpd.conf, even if I deleted the reference to the mysql function. I have this setup running perfectly on a Debian box for years, but Debian doesn't have the RAID driver for my Dell PowerEdge 1850, so I'm stuck.

    For now, I installed vsftpd with yum and it pretty much worked after modifying vsftpd.conf and just

    /etc/init.d/vsftpd start

    But I only have it working with system users, so that kind of sucks, I really need to have mysql and virtual users, but ran out of time. But at least people stopped screaming at me because they could upload to their home dir's, so I guess good enough until I get something else figured out :)

    Thanks,
    Cameron Camp
    San Diego
     
  8. unclecameron

    unclecameron New Member

    Hey Falko and Till, thanks for the help, I just signed up as a supporter, do you have those images on Xen?
    Thanks,
    Cameron Camp
     
  9. falko

    falko Super Moderator ISPConfig Developer

    You mean, instead of VMware images? No, I'm sorry, we only have VMware images.
     

Share This Page