Fedora 12, ISPConfig 2, OpenX 2.8.4 - CPUs random 100% usage

Discussion in 'Server Operation' started by macmillaninc, Feb 6, 2010.

  1. macmillaninc

    macmillaninc New Member

    I have recently upgraded to Fedora 12. I am running ISPConfig 2 and OpenX 2.8.4.

    At apparently random times both CPUs usage spikes to 100% and will not come down without a restart. There is no obvious process running.

    What could it be?
     
  2. macmillaninc

    macmillaninc New Member

    Could be a maintenance routine in OpenX. I have disabled them and it seems that I am not having the problem. We shall see.
     
  3. macmillaninc

    macmillaninc New Member

    Nope. Not that. Just had it again. Both CPUs pegged at 100%. Restart is the only option.
     
  4. falko

    falko Super Moderator

    Any errors in your logs?

    Do you have munin installed? That could help you track down what the problem is.
     
  5. macmillaninc

    macmillaninc New Member

    I am not even sure what log to view. I get an encoding error when trying to view some of the logs in /var/log. Should I look elsewhere?

    No, I do not have munin installed.
     
  6. macmillaninc

    macmillaninc New Member

    I have read that Pulseaudio might be an issue. Your thoughts on that?

    Please pardon my lack of knowledge about this server. Sometimes I question why I even set it up, lol
     
  7. falko

    falko Super Moderator

    I'm afraid I can't say anything about Pulseaudio...

    You can try to view the logs with cat, vi, or tail. See
    Code:
    man cat
    man vi
    man tail
     
  8. macmillaninc

    macmillaninc New Member

    I need your guideance. I cannot seem to find which log might display this error. The CPU issue seems to only happen when I am asleep.

    Anyway, I know that I should not be driving this system as I am unqualified. LOL I am learning more and more though.

    I had the error last night, what log might tell me what happened?
     
  9. falko

    falko Super Moderator

    I'd check all logs in the /var/log/ directory.
     
  10. macmillaninc

    macmillaninc New Member

    I am not finding any hints in these logs.

    I have turned off the email reports in OpenX. We are thinking that there may be a relationship to the reports generation in OpenX and the CPU issue. More to come...
     
  11. macmillaninc

    macmillaninc New Member

    Apparently, this issue stems from the automatic reports that are generated and emailed by OpenX. I have disabled all of the auto-reporting and have not had a reoccurance of this problem.
     
  12. macmillaninc

    macmillaninc New Member

    Okay, that was not it. I am perplexed! I need help on what log to read. The error occured at 9:06 local time last night. Where can I look for this? ispconfig does not have a log that I can find either.
     
  13. falko

    falko Super Moderator

    I suggest you install munin as it might help you track down the problem.
     
  14. macmillaninc

    macmillaninc New Member

    This appears to be Denial of Service (DoS) or Brute-Force attacks on the server. Any idea how I can block them? I need only allow access from a few IP addresses.
     
  15. falko

    falko Super Moderator

  16. macmillaninc

    macmillaninc New Member

    They are never the same (as far as I can tell) but are all in China.

    Is there a similar way that I can allow only the IP addresses that I want to grant access?
     
  17. falko

    falko Super Moderator

  18. macmillaninc

    macmillaninc New Member

    I have located the offending IP addresses and the attacks have stopped. Thank you for helping me figure this out.
     

Share This Page