[fcgid:warn] Error while trying to install CMS

Discussion in 'General' started by simonfr, Oct 22, 2015.

  1. simonfr

    simonfr New Member

    I'm trying to install WHMCS on fresh Debian 8 ISPCONFIG installation. I've tried PHP-FPM, FAST-CGI active desactive suExec and other things to don't have 500 error while installer is creating database (I think). In the error.log I got these 2 errors :
    [Thu Oct 22 11:32:24.400045 2015] [fcgid:warn] [pid 17959] (104)Connection reset by peer: [client xxx.xxx.xxx.xxx:42806] mod_fcgid: error reading data from FastCGI server, referer: http://xxx.com/clients/install/install.php?step=4
    [Thu Oct 22 11:32:24.400182 2015] [core:error] [pid 17959] [client xxx.xxx.xxx.xxx:42806] End of script output before headers: install.php, referer: http://xxx.com/clients/install/install.php?step=4
    Does anyone have an idea how I can resolve this error ?

    Thank's a lot
    Last edited: Oct 22, 2015
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Use php mode php-fcgi or php-fpm and ensure that suexec is on.
    2) Upload whmcs either with the ftp user of the website or chown the files to the web user and client group.
    3) turn off custom error pages in the website settings, in case whmcs throws HTTP errors then you can see the message sent by whmcs.
  3. simonfr

    simonfr New Member

    Thank you,
    I've resolve my error with your help. Now I've a problem with API :
    SOAP Error: Could not connect to host (When HTTPS enabled)
    SOAP Error: Bad Request (When HTTPS disabled)
  4. simonfr

    simonfr New Member

    Okay I've resolved the error by adding this :
    'stream_context'=> stream_context_create(array('ssl'=> array('verify_peer'=>false,'verify_peer_name'=>false)))

    Now when I ask ISPConfig api to add client, domain service ect ... I get this from ISPconfig API : "Internal Server Error" and in error.log :
    [Fri Oct 23 17:20:56.546568 2015] [fcgid:warn] [pid 30671] (104)Connection reset by peer: [client 2001:41d0:8:xxxx::1:48878] mod_fcgid: error reading data from FastCGI server
    [Fri Oct 23 17:20:56.546744 2015] [core:error] [pid 30671] [client 2001:41d0:8:xxxx::1:48878] End of script output before headers: index.php
  5. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    seems, that you ssl-cert could not be verified. you can try to add the intermediate-certs as bundle.
  6. simonfr

    simonfr New Member

    I've found an other solution which is to add this "'stream_context'=> stream_context_create(array('ssl'=> array('verify_peer'=>false,'verify_peer_name'=>false)))".

    Now I've this problem :

  7. simonfr

    simonfr New Member

    How I can get more details about this error ?

Share This Page