FCGID or PHP broken

Discussion in 'General' started by rdhir, Jul 3, 2012.

  1. rdhir

    rdhir New Member

    OK, I have had a perfectly functioning ISPConfig setup running for a while.

    Its based on a CentOS 6.2 vm run at Bytemark.co.uk.

    I recently issued a yum install update and seem to have broken my system in a subtle way.

    ISPConfig ( seems to work fine.

    However I am running various wordpress sites and while they deliver content, various configuration pages are broken. It seems to be related to FCGID as I get the following errors in the server log for any site

    [Tue Jul 03 17:07:46 2012] [warn] [client *.*.*.*] mod_fcgid: stderr: PHP Warning:  require(): open_basedir restriction in effect. File() is not within the allowed path(s): (/var/www/clients/client5/web20/web:/var/www/clients/client5/web20/tmp:/var/www/www.clientdomain.com/web:/srv/www/clientdomain.com/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin) in /var/www/clients/client5/web20/web/wp-admin/admin-header.php on line 110, referer: http://www.clientdomain.com/wp-admin/index.php
    [Tue Jul 03 17:07:46 2012] [warn] [client *.*.*.*] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server, referer: http://www.clientdomain.com/wp-admin/index.php
    [Tue Jul 03 17:07:46 2012] [warn] [client *.*.*.*] (104)Connection reset by peer: mod_fcgid: ap_pass_brigade failed in handle_request_ipc function, referer: http://www.clientdomain.com/wp-admin/index.php
    I have tried various things such as changing to CGI, Mod PHP and SU PHP but I just get a different set if errors.

    I have tried editing the .php-fcgi wrapper file to eliminate openbasedir, but I think thats just a symptom as I still get the 104 errors. It is as if PHP can't read a list of some kind, as simple pages work but pages which should contain a list it items taken from the database don't

    Happy to provide more info if you tell me what you need.

    Linux kernel is
    php.i686 is 5.3.3-3.el6_2.8
    httpd.i686 is 2.2.15-15.el6.centos.1

    Any help gratefully received


  2. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Ensure that all files in /var/www/clients/client5/web20/web and its sub directoris are owned by the web user and client group of the website.
    2) Check the website settings, php mode should be php-fcgi and the suexec checkbox must be enabled.
  3. rdhir

    rdhir New Member

    Checked the from /var/www/www.clientdomain.com/ and all files are owned by the correct owner group combination

    Similarly in the control panel

    suexec is ticked and Fast-CGI is selected as the PHP mode.
  4. rdhir

    rdhir New Member

    Further Clues

    ok after more investigation I can make it work a little bit better, but I still get plenty of time outs in the admin pages.

    a) I temporarily hacked /var/www/php-fcgid-scripts/xxx/.php-fcgi-starter

    I set openbasedir = "none"

    some configuration pages started to work.

    b) I changed the timeout values as follows

            FcgidIdleTimeout 300
            FcgidProcessLifeTime 3600
            # MaxProcessCount 1000
            FcgidMinProcessesPerClass 0
            FcgidMaxProcessesPerClass 100
            FcgidConnectTimeout 20
            FcgidIOTimeout 3600
            FcgidBusyTimeout 300
    previously they used older? names eg IdleTimeout

    I am still getting fails on configuration pages which are extracting longer lists from MySQL

    yum reports mod_fcgid

    mod_fcgid.i686 2.3.7-1.el6 @epel

    So did an update somehow make fcgid need different names for parameters and perhaps change openbasedir or the location of some temporary file?
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Then you havent selected the correct fcgi configuration mode for your apache version in system > server config in apache.

Share This Page