fcgi error 104 connection reset by peer

Discussion in 'General' started by dragostini, Dec 25, 2013.

  1. dragostini

    dragostini New Member

    did a fresh install using http://www.howtoforge.com/perfect-server-centos-6.0-x86_64-ispconfig-3

    Everything seemed to install fine.

    Try to visit https://mydomain.com:8080 gives the errors:

    [Wed Dec 25 01:04:06 2013] [warn] [client NN.NN.NNN.NN] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
    [Wed Dec 25 01:04:06 2013] [error] [client NN.NN.NNN.NN] Premature end of script headers: index.php

    (N = number)

    been googling for hours...also am still idle in #php irc channel on freenode.

    Some of the guys there did some poking around with me, we added a small snippet addition to the index.php of the ISPConfig3 login page just to see if my install was working (basically, just showing "Meh" as text on the screen) and that worked fine, so it's making it TO the login page, but once I removed that little snippet the error resumed.

    disabled suexec and still happens.

    Any ideas?
  2. betafer

    betafer New Member

    same problem, hope you find a solution
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Suexec has to be on in any case, it will not work without it.

    The most likely reason is that you missed a step or package of the apache configuration form the guide, I installed a server a few days ago for a customer using the guide and it worked out of the box, so there is neither a issue in the guide nor in ispconfig, there must be something that you left out or your centos base setup was not ok e.g. when you installed another controlpanel first which changed some base files from apache.

Share This Page