fc6 + ISPConfig + suexec (using suPHP?)

Discussion in 'Installation/Configuration' started by zetnsh, Aug 23, 2007.

  1. zetnsh

    zetnsh New Member

    Hi there,

    OK - having got suPHP working nicely with ISPConfig (see this post), thought it was time to tackle CGI scripts too.

    I was going to bash ahead and try to get suPHP to run my CGI's for me, but I realised that in fact I have a more fundamental error, from the logs:

    Code:
    [Thu Aug 23 08:42:17 2007] [error] [client 88.97.179.134] Options ExecCGI is off in this directory: /var/www/web1/web/test.cgi
    I think I should probably not try to go any further until I solve this one! Now - of itself, this isn't a problem, it's easy enough to add the ExecCGI directive in somewhere. My question is - how do you do that in a repeatable way without ISPConfig eating your modifications?

    Any help much appreciated!

    When I've got that sorted out, and I've managed to get suPHP running CGI's, I'll post how I managed to acheive it :) (assuming I do manage to acheive it!)

    Thanks,

    Neil
    Neil S Hamilton, Web Outreach
     
  2. zetnsh

    zetnsh New Member

    Oh - one last note, CGI scripts ARE enabled for the site in question, within ISPConfig
     
  3. falko

    falko Super Moderator

    You must place your CGI scripts in the cgi-bin directory (/var/www/web1/cgi-bin), or you use the Apache Directives to configure something else (e.g. something like
    Code:
    <Directory /var/www/web1/web>
     Options +ExecCGI
    </Directory>
    )
     

Share This Page