FC5 & Frontpage Server Extensions (FPSE)

Discussion in 'Server Operation' started by mmek, May 8, 2006.

  1. mmek

    mmek New Member

    Hello,

    Has anyone had any success installing the Frontpage Server Extensions (FPSE) on FC5? If yes, can you let me know how?

    Thanks.
     
  2. PortMan

    PortMan New Member

    Did you ever get this working? I'm looking at attempting this but don't want to mess anything up until I can find instructions on how to do it.

    thanks.
     
  3. falko

    falko Super Moderator ISPConfig Developer

  4. PortMan

    PortMan New Member

    Thank you much! I searched for documentation, but must have looked right over this.
     
  5. PortMan

    PortMan New Member

    I'm running into an error on this installation that is outlined at http://www.howtoforge.com/linux_apache2_frontpage2002

    The error:

    Error: Command failed with rc=65536
    ERROR: Unable to install mod_frontpage dso
    Exiting due to an error! Please fix the error and try again.

    I have verified that httpd_devel is installed. I'm thinking this has something to do with Apache 2.2 but am not sure.

    Has anyone gotten FPSE to work on Fedora 5 with Apache 2.2? If so, what directions did you follow.
     
  6. falko

    falko Super Moderator ISPConfig Developer

    I haven't worked with Frontpage for years because it's a nightmare to set up. I'm quite happy with FTP. :)
     
  7. Hi,

    Has anyone come up with a solution to Portman's issue above?

    I too am running:
    - Fedora Core 5 (FC5)
    - Apache 2.2
    - Have installed httpd-devel
    - Trying to install Frontpage server extensions 2002 (FPSE)

    I get the following error while installing FPSE:
    ...
    Using the Apache apxs utility to build mod_frontpage.so
    /usr/lib/apr-1/build/libtool --silent --mode=compile gcc -prefer-pic -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -DLINUX=2 -D_REENTRANT -D_GNU_SOURCE -D_LARGEFILE64_SOURCE -pthread -I/usr/include/httpd -I/usr/include/apr-1 -I/usr/include/apr-1 -Dlinux -c -o /usr/local/frontpage/version5.0/apache2/mod_frontpage.lo /usr/local/frontpage/version5.0/apache2/mod_frontpage.c && touch /usr/local/frontpage/version5.0/apache2/mod_frontpage.slo
    /usr/local/frontpage/version5.0/apache2/mod_frontpage.c:65:25: error: apr_compat.h: No such file or directory

    The most that I have been able to find out is that there were some changes made to Apache somewhere between Apache v2.0 and 2.2 which removed some include files (.h) that FPSE appears to be dependent on.

    FPSE has been discontinued by Microsoft earlier this year, so there is no longer direct support for FPSE.

    Any suggestions would be greatfully received!
     
  8. falko

    falko Super Moderator ISPConfig Developer

    That's all I could find: http://www.fedoraforum.org/forum/archive/index.php/t-120358.html :(
     

Share This Page