FC4 Perfect Setup Access from WAN

Discussion in 'HOWTO-Related Questions' started by wookie, Aug 19, 2006.

  1. wookie

    wookie New Member

    Ok, you got me. This is the first time I have ever posted to any forum, so please be gentle. I have only been in the Linux community for a year or so and still have a lot to learn. Here is my problem:
    I installed the FC4 following the Perfect Setup howto and it worked like a charm. Also installed ISPConfig and it too was painless. From inside my LAN I can browse to the ISPConfig login screen and a test web that I created. When I try to access anything on the FC4 box from the Internet, it fails. Information about the network and such:

    Natted LAN behind a PIX firewall.
    FC4 running in vmware server virtual machine. (AMD 64 bit processor 2 GB RAM)

    Here's what I have done so far:

    1. Set up PIX ACL to translate IP address to point to server.
    2. Attempted to FC4 Box from Internet. Failed.
    3. Confirmed that neither the vmware host, FC4 VM or ISPConfig firewalls are running.
    4. Shutdown FC4 VM and brought up 2K3 Server, assigned same internal address as FC4 and was able to ping the 2K3 Server from the Internet.
    5. Shutdown 2K3 VM, restarted FC4 (so there would be no IP conflict) and added Public IP address to eth0:1 (just in case).
    6. Tried to ping from Internet. Failed.

    I'm stumped. Could someone point me in the right direction. I spent the last two days searching the forums for a possible solution and can't seem to find it.

    Should I be able to reach the ISPConfig login via IP address as opposed to Domain Name?

    Thanks in advance.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Both works (if your domain's DNS records are ok).

    Did you forward the necessary ports from your router to your FC4 system?
    Is SELinux disabled on your FC4 system? What's the output of
    Code:
    iptables -L
    ?
     
  3. wookie

    wookie New Member

    Falko,

    First let me say thank you for a marvelous board and the super HowTo's.

    All ports are open on the firewall allowing traffic to the FC4 system, 21, 25, 110,80, 81 via "fixup" commands on the PIX and ACLs which pass the traffic from Public to private IP address. SELinux disabled on both FC4 guest and FC5 host systems. Output of iptables -L:

    [[email protected] ~]# iptables -L
    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain INPUT (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

    Thanks again for your help.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    This is all ok, so I guess it must be some router setting...
     
  5. wookie

    wookie New Member

    OK, I'll go back to the router/firewall drawing board. When I fix this (and I KNOW I will) I'll post what was wrong for the good of the community. Again, vielen danke for a marvelous site. :cool:
     
  6. falko

    falko Super Moderator ISPConfig Developer

    It's also possible that your ISP is blocking certain ports, such as port 80. Please ask them about it.
     
  7. wookie

    wookie New Member

    Resolved

    Ok, Now I really feel like an idiot. I scrapped the FC4 setup and went with the Ubuntu (Dapper Drake) Perfect setup and the same problem occurred. Finally discovered that the Netopia Wireless Router provided by my ISP had "Stateful Inspection" turned on by default and it was not allowing my IP address to be visible from the Internet. After properly configuring the Netopia, I was able to access everything from the web.

    Thanks for a marvelous How To. Using Putty to copy and paste is definitely the way to go. I am looking forward to learning a bit about ISPConfig.
     

Share This Page