fatal: proxy:mysql:/etc/postfix/mysql-virtual_domains.cf(0,lock|fold_fix): table lookup problem

Discussion in 'Server Operation' started by spazio, Mar 8, 2016.

  1. spazio

    spazio Member

    Hi all,
    I have a weird crash/problem that happend yesterday.
    Server (Ubuntu 10.04.4 LTS (Lucid Lynx)) ISPConfig 3.0.5.4p8
    The server is running since a couple of years without any problem.
    Yesterday around noon the postfix email server stop working.
    The only way I was able to make it work again was to restart the server.
    12 hours later, the same problem came back.
    Here is the mail.err log:
    Mar 7 19:38:46 server postfix/trivial-rewrite[9983]: fatal: proxy:mysql:/etc/postfix/mysql-virtual_domains.cf(0,lock|fold_fix): table lookup problem

    Here is the syslog :
    Mar 7 06:45:38 server postfix/smtpd[2926]: warning: problem talking to service rewrite: Success
    Mar 7 06:45:38 server postfix/smtpd[2835]: warning: problem talking to service rewrite: Connection reset by peer
    Mar 7 06:45:38 server postfix/master[2090]: warning: process /usr/lib/postfix/trivial-rewrite pid 21749 exit status 1
    Mar 7 06:45:38 server postfix/master[2090]: warning: /usr/lib/postfix/trivial-rewrite: bad command startup -- throttling

    After multiples lines
    Mar 7 06:47:21 server postfix/trivial-rewrite[22267]: fatal: proxy:mysql:/etc/postfix/mysql-virtual_domains.cf(0,lock|fold_fix): table lookup problem

    Nothing was change on the server as config/files or other.

    I search for this kind of error but it always was related to misconfig with postfix files. In this case, since the server is running for some time it can't be a misconfig. Also the 2 times it was crash. After a restart it work ok for some time!

    Any pointers as to where I should search would be appreciated.

    Thanks
    Spazio
     
  2. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    You should fix this: bad command startup -- throttling
     
  3. ztk.me

    ztk.me Active Member

    First of all check this thread ( the end ) https://www.howtoforge.com/community/threads/postfix-trivial-rewrite.37089/
    The issue here has been an added "proxy" prefix to the lines - it just appeared.

    But if it just appeared out of the sudden without any upgrade or touching config files / settings
    I'd recommend to check your available disk space $df -h
    check your raid ( if any ) if you have softraid do $cat /proc/mdstat - for hardware raids you might need something else.
    Check your disk health with $smartctl -a /dev/sda ( change sda with your disk name )
    Make backups of important data and try a short/long/offline test
    $smartctl -t <short|long|conveyance|select> /dev/sda
    Do a file system check if it still looks good
    $fsck -v -f -c /dev/sda1 ( change it accordingly and check all partitions ).
     

Share This Page